Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Asrock Extreme Gen3 wont get past UEFI screen




  1. #1
    Join Date
    Aug 2011
    Location
    Lindale, TX
    Posts
    4

    Default Asrock Extreme Gen3 wont get past UEFI screen

    hello,
    So I just recently ordered new parts for my system to upgrade from a very old and broken Desktop.
    I put everything together in my case and didn't get any video whatsoever on 3 different monitors with the same 2E and 30 debug codes. I took everything back out and bench tested and found out the first 2 dimm slots werent working. So I reseated everythig (Cpu, Ram, Video card) and finally I got something on the screen. I then got excited and put everything back in the case. (Before I get to far understand this is my 3rd build and first time with a Corsair H80. So putting everything in and out a few times has already pissed me off) So after I put it all back in I check to make sure it still boots and there is no short. It comes on but I keep getting this screen and an A3 debug code that i can't seem to fix no matter what i do.

    I have a logitech G510 keyboard (USB) and it won't let me access UEFI/Bios or any other keys that i press don't do anything. It just goes to this screen and doesn't move. If I have devices plugged in it shows it on the screen but still nothing. I've unplugged everything off the Mobo including both HDDs and CD Drive. Still get A3 and can't access bios, does anyone know what to do or have an suggestions...If i can't get the board working tonight I'll probably RMA for another and hope it works, if not. Well at least i gave it a chance.

  2. #2
    Join Date
    Aug 2011
    Location
    Lindale, TX
    Posts
    4

    Default Re: Asrock Extreme Gen3 wont get past UEFI screen

    I forgot to mention my specs.
    Antec 900 V2
    Antec Truepower 650w PSU
    ASRock Z68 Extreme 3 Gen3
    Intel i5 2500k
    Corsair H80
    Gskill ripjaws X series 2x2gb 1600mhz at Cas 6 lat
    Last edited by Mastachute; 08-31-2011 at 12:07 AM.

  3. #3
    Join Date
    Aug 2011
    Location
    Lindale, TX
    Posts
    4

    Default Re: Asrock Extreme Gen3 wont get past UEFI screen

    Anyone? I just wanna know if there is any other troubleshooting tips I should try before I go for an rma?

  4. #4
    Join Date
    Jul 2011
    Location
    Seattle
    Posts
    37

    Default Re: Asrock Extreme Gen3 wont get past UEFI screen

    Try a ps2 keyboard maybe.

  5. #5
    Join Date
    Mar 2011
    Location
    Taiwan
    Posts
    562

    Default Re: Asrock Extreme Gen3 wont get past UEFI screen

    Dear brukster,

    Please kindly use another mouse to check whether the symptom still occur.

    Thanks!

    Have a nice day
    ASRock TSD Emily

  6. #6
    Join Date
    Aug 2011
    Location
    Lindale, TX
    Posts
    4

    Default Re: Asrock Extreme Gen3 wont get past UEFI screen

    So should I try a different keyboard then? I'll have to wait a day or too I guess then to drive back and grab my old ps2 keyboard. I only brought my Logitech G510 keyboard and G9 mouse with me.
    Is there anything else I can do to see if it'll work?

  7. #7
    Join Date
    Jul 2011
    Location
    Belgium
    Posts
    3

    Default Re: Asrock Extreme Gen3 wont get past UEFI screen

    Please try another USB-keyboard. I'm having similar problems with Z68 Extreme 4 and Logitech G110 : my pc keeps rebooting ...

    Have started another thread ...

    According to ASrock Netherlands (got a lot of info from there), it could be a problem with uefi ...

  8. #8
    Join Date
    Jun 2011
    Location
    Holland
    Posts
    3

    Default Re: Asrock Extreme Gen3 wont get past UEFI screen

    Brother i had the same kind of problem with a steelseries xai mouse
    the mobo would not allow me to login to windows unless i unplugged the mouse..

    what u can do is try to connect the keyboard into a usb 3.0 port (if u havent tried that)

    otherwise try to enable or disable one of the things at the usb section in the bios...

    but before doing that try reading some about it..

    Goodluck

  9. #9
    Join Date
    Sep 2011
    Location
    new york
    Posts
    7

    Default Re: Asrock Extreme Gen3 wont get past UEFI screen

    I forgot to mention my specs.


  10. #10
    Join Date
    Mar 2011
    Location
    Taiwan
    Posts
    562

    Default Re: Asrock Extreme Gen3 wont get past UEFI screen

    Dear all,

    Please kindly provide your e-mail and model name for me, I will send BIOS to you for testing.

    Thanks!

    Have a nice day
    ASRock TSD
    Emily

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •