Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 4 of 4

Thread: Asrock Z68 Pro 3 + MSI GTX 580 Lightning issue




  1. #1
    Join Date
    Sep 2011
    Location
    Finland
    Posts
    7

    Question Asrock Z68 Pro 3 + MSI GTX 580 Lightning issue

    Hi Asrock forum!

    I have just bought a new computer with the following hardware:

    Asrock Z68 Pro 3
    Intel i5 2500k
    8gb 1600mhz ram (2x4gb in dual channel)
    MSI GTX 580 Lightning
    Corsair HX650W PSU

    Now the issue I am having is that my motherboard is not finding my graphics card. It is installed in the PCI-E slot.
    I have tried the graphics card in my old rig and it was working fine. I have also tested my old card (ATI Radeon HD4800 series) in this new MB and it worked.
    MB found my old card right away and I got to install drivers. I updated the asrock Z68 Pro 3 bios to newest version (1.60) but that didn't help eather.

    I also installed the new PSU I got from Corsair to my old rig and the new graphics card worked with it in my old rig. So it is not the PSU eather.

    Any ideas ?

  2. #2
    Join Date
    Sep 2011
    Location
    Finland
    Posts
    7

    Default Re: Asrock Z68 Pro 3 + MSI GTX 580 Lightning issue

    Just wanted to add that I have managed to install Windows 7 and all the MB drivers using the onboard graphics card. Also Win7 is up to date. Device manager is not showing my GTX 580 Lightning and I cannot install any drivers for it.

  3. #3
    Join Date
    Mar 2011
    Location
    Taiwan
    Posts
    562

    Default Re: Asrock Z68 Pro 3 + MSI GTX 580 Lightning issue

    Dear Aenpar,

    After we test, GTX 580 can work on Z68 Pro3 normally and below is our test configuration.
    CPU: i5-2500k
    Memory: ADATA DDR3-2000 4GBx2
    VGA card: MSI N580GTX-M2D15D5
    PSU: Thermaltake 750W
    BIOS: P1.60
    VGA driver: 280.26
    OS: Windows 7 64bit

    Please kindly refer to below suggestions for testing.
    1. Load BIOS default settings to try.
    2. Use eraser to clean the golden finger of VGA card to try.
    3. Check the power connector of VGA card is installed correctly.
    4. Reinstall the VGA card driver from below link to try.
    Link: NVIDIA DRIVERS 280.26 WHQL

    If the problem still cannot be solved, please kindly contact your local dealer to check your system.

    Thanks!

    Have a nice day
    ASRock TSD Emily

  4. #4
    Join Date
    Sep 2011
    Location
    Finland
    Posts
    7

    Default Re: Asrock Z68 Pro 3 + MSI GTX 580 Lightning issue

    Hi!

    Nothing helped. I can't install nvidia drivers because card cannot be found. So I will return this MB and take Asus board instead.

    Thank you!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •