Hello all,

So, a few months ago I was having some problems with my SATA devices (I have a 1TB Western Digital Caviar Black and a Sony DVD burner hooked up). Basically, it was taking longer and longer for the mobo to detect my SATA devices on POST, and finally, my computer wouldn't boot anymore.

On a whim, I tried connecting my two SATA devices to different SATA ports (they had been plugged into ports 1 & 2, and I switched them to 4 & 5). This worked perfectly. Suddenly the mobo was detecting the SATA devices on post almost immediately. The computer also seemed to be running smoother in general.

However, more recently, the POST process was again a drag. This morning (while running the new FIFA 12 demo, which seems awesome), my computer locked up. Ctrl-alt-del to no avail. So, after hardbooting, POST was taking forever. It did seem to finally detect the devices, but then would bring me to a black screen with the ASCII text "Cannot read drive, press ctrl-alt-del to reboot". At least, I think that's what I remember it saying.

So, I tried my solution again. This time, I just unplugged the DVD burner (haven't used it in ages anyway), and plugged the WD drive into SATA port 3, the only 1 of the 5 I have yet to use. Again, instantaneous detection on POST and no problems.

So, my question is, what is going on here? I'm worried that I'm slowly frying my SATA ports. Is this possible? Has anyone else had this kind of experience? Any thoughts at all?

Thanks for the help,
Chip

ASROCK H55M Pro LGA 1156
Intel i3-530
2GBx4 GSKILL F3-12800CL9D-4GBRL
1TB WD HD WD1001FALS
XFX HD5850
Windows 7 Home Premium