Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: ASRock 880G Pro3 Help Please




  1. #1
    Join Date
    Sep 2011
    Location
    fargo nd usa
    Posts
    2

    Default ASRock 880G Pro3 Help Please

    Hello I just purchased the Asrock 880g pro 3 mother board. I have a couple of issues.
    1. I cannot get into the Bios. There is no post or the screen stays blank with no post. I have tried holding down f2 or pressing it repeatedly but still no set up bios. The system goes straight to the OS.
    2. Every time I try to turn off the computer using shut down it keeps restarting. I always click shut down and it acts like it is shutting down but it always restarts. The only way I have been able to turn off the system is by turning the power supply off.
    Please advise me on how to correct these issues.

    System
    ASRock 880G Pro3
    AMD Ph II X6 2.6g
    16g GSkill sniper DDR3
    700 watt psu
    8800gts
    2 tb wd hd

  2. #2
    Join Date
    Sep 2011
    Location
    fargo nd usa
    Posts
    2

    Default Re: ASRock 880G Pro3 Help Please

    Wow this board is kinda disappointing. I did figure out why it wouldn't shutdown. On the board there is a power button and reset button and because of my poor cable management one of the sata cables was pressing the power button. I got that fixed. On to my 2nd issue. I am not able to boot into the UEFI if I have a graphics card occupying the pcie slot. If I remove the gpu and plug into the on board I can get into the UEFI. Its pretty inconvenient and I haven't found a solution. I have tried turning the on board off and making the pcie the primary video but this doesn't help. Pretty lame ASRock usually has pretty solid products but this 880g pro3 is irritating. I also have a new question. Does anyone here have experience with the UEFI on this board? I'm trying to overclock my AMD Phenom X6 1035T 2.6 cpu and I have no options for HT or NB multipliers that I have found. Does anyone know where these are? I do not have the black edition so I need to mess with the clock speeds and with the absence of an HT and NB multiplier it makes it difficult. Thanks for any help.

    My build:
    700watt psu
    AsRock 880g Pro3 Mobo
    AMD Phenom X6 1035T 2.6 cpu
    16g G.Skill Sniper 1333
    8800 GTS (lame but Im upgrading soon to a 6870)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •