Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 5 of 5

Thread: Z68 Extreme4 Gen3 Not Entering Bios




  1. #1
    Join Date
    Sep 2011
    Location
    Mckinney, TX
    Posts
    3

    Default Z68 Extreme4 Gen3 Not Entering Bios

    Hi All,

    I just got the board yesterday. Everything went well with the building, but the first boot confused me. I pressed the power button and started to press DEL immediately so I can enter the UEFI BIOS for the first time, and then nothing..... I went on pressed TAB so the logo screen would switch off, and it says "Entering Setup". I sat and waited about 2 mins, but nothing happened. Powered off the system, and this time I waited a little before I start pressing DEL, suprisingly, it went into the BIOS. I went ahead and setup RAID for my HDDs, then reboot. First time, I couldn't go into BIOS again. Second time, I let the system go through the RAID controller spill and after it went back to the original logo screen I pressed DEL, it went to BIOS. Is this normal?? Thanks!

  2. #2
    Join Date
    Sep 2011
    Location
    Melbourne, Australia
    Posts
    9

    Default Re: Z68 Extreme4 Gen3 Not Entering Bios

    No this is not normal. I'm having the same problems with the fatal1ty z68 pro gen 3 mobo.
    Have contacted Asrock and waiting for a reply. Seems to me that the Asrock mobos bios is
    full of glitches. Have had several other bios related problems as well. Will post reply from Asrock
    when I receive it.

  3. #3
    Join Date
    Sep 2011
    Location
    Mckinney, TX
    Posts
    3

    Default Re: Z68 Extreme4 Gen3 Not Entering Bios

    Situation got worse, now I can only go into UEFI and it will not boot to windows anymore. I called asrock, they told me the board is bad. Just returned it. I am very disappointed since the board looked so promising. Think I will go with ASUS for the next board. Spending hrs installing and uninstalling is totally waste of time.

  4. #4
    Join Date
    Oct 2011
    Location
    Tacoma, WA
    Posts
    5

    Default Re: Z68 Extreme4 Gen3 Not Entering Bios

    hello,
    Where did you find a number for Asrock at. I have been trying to find a number on their website but all I can find is the darn web support request form that they don't respond to.


    Thanks,
    James

  5. #5
    Join Date
    Sep 2011
    Location
    Mckinney, TX
    Posts
    3

    Default Re: Z68 Extreme4 Gen3 Not Entering Bios

    1-909-590-8308 good luck! I worked with Eric. Knowledgable and friendly. Hope you work your issue out!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •