Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 4 of 4

Thread: Mother Board Dead out of box??




  1. #1
    Join Date
    Sep 2011
    Location
    Kalgoorlie, Western Australia, Australia
    Posts
    3

    Default Mother Board Dead out of box??

    HI all,

    Building an all new system and fitted a Extreme 7 gen 3 board, I am using a corsair AX850 power supply, I have all my board plumbed up except for the cpu ( waiting for it to arrive ). I decided to
    power up so I could check the fan operation and fan controller, nothing happened, all dead.
    Test the power supply, checked my+5vSB (5v ) and PS_ON ( 4.5v )feeds, all good, tested power switch, all good, checked voltage at power header ( 3.4v ), checked ground circuit from header to atx connector, check ok
    I am finding that the PS_ON feed to the power supply is not changing state. ( ie when the power switch is pressed the feed should drop below 1v to tell the power supply to start up. I tried the on board power switch, no result and
    tried shorting the power switch pins at the header and still no joy.

    After all that the big question is...... Does my Asrock board require a cpu present in order to trigger the psu??

    My understanding is that the board will power up, the fans power up, everything as normal except it will not post ( boot up ) as the cpu is missing.

    Any help would be good, I tried googling but all the results were from like 2002 ...lol
    Attached Images Attached Images Mother Board Dead out of box??-angry-pc-user-gif 

  2. #2
    Join Date
    Jun 2011
    Location
    Australia
    Posts
    32

    Default Re: Mother Board Dead out of box??

    from memory, most boards dont require a CPU to boot (but still dont post like you said), some may need one though, wait untill the CPU comes, give it a go and then if its still rooted then warranty it or return it? and replace?

  3. #3
    Join Date
    Sep 2011
    Location
    Kalgoorlie, Western Australia, Australia
    Posts
    3

    Default Re: Mother Board Dead out of box??

    Hi all,

    Just to let you know the mother board was faulty and a replacement was sent back, I hope that is all the trouble I get with an Asrock board.

    Looking through the forums makes me nervous about what other faults I may encounter. Finger's crossed.... lol
    ************************************************** ********************************
    Case - Cooler Master Haf X
    Mother Board - Asrock Extreme 7 Gen 3
    Cpu - Intel I7 2600K
    Memory - G.Skill 2133mhz 8 GIG
    Power Supply - Corsair AX850
    Graphics - EVGA GTX460 1 gig oc SLI
    ************************************************** ********************************

  4. #4
    matter2003 is offline Junior Member
    Join Date
    Oct 2011
    Location
    new york
    Posts
    32

    Default Re: Mother Board Dead out of box??

    Did u make sure u didn't have the mobo screwed down too tight? It shorts out the board and it appears dead, but when u loosen the screws it works normal...I am willing to bet a lot of DOA mobo's are simply being shorted out on install..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •