Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Various problems with ASRock Z68 GEN3 extreme7




  1. #1
    Join Date
    Oct 2011
    Location
    QC, Canada
    Posts
    20

    Question Various problems with ASRock Z68 GEN3 extreme7

    Hello,

    I'm having a few issues with my new ASRock Z68 gen3 extreme7 and was hoping at least some of them could be fixed.

    1) Mouse axis inverted in UEFI. I know this one is common, just listing it. Mouse is a Razer Lachesis.

    2) Keyboard (Logitech G510) was not recognized by the BIOS in any port, there was a message indicating 2KB detected but it didn't work at all. Had to pull out an older keyboard which worked for the BIOS.

    3) Slow boot time, it takes around a minute maybe a bit more before the splash screen even appears. This is extremely slow compared to my previous motherboard.

    4) This one is a bit weird and I'm not sure it's the motherboard but installing windows 7 took over an hour. Using the same ODD and a similar SSD (recently installed on a Intel X25-M, a OCZ Vertex and a OCZ Agility 3) on another motherboard, it usually takes 15-20 minutes. I tried removing everything except the ODD and the SSD, I also tried changing the amount of ram (4gb, 8gb, 16gb) but nothing seemed to help.

    5) It took 14 tries to get the video cards recognized and I know the cards are functional because they were installed in my previous build. Didn't get any output from the video card, thankfully this is a z68 so I managed to temporarily bypass the issue by using the onboard video and completely removing the vid cards. Could be an installation issue.

    6) RAM profile was properly detected but not used, instead of the expected 1600mhz, 8-8-8-24, the bios went for 1333, 9-9-9-24 2T. Not really a bug but just annoying. Didn't dare set it manually before installing windows but I'll try changing it tonight.

    I didn't try updating the bios yet but that was my next step.

    BTW I plan on overclocking this build a bit (4 - 4.2Ghz).

    Thank you in advance for any help or suggestions you can provide.

    Complete hardware specification
    MOBO: ASRock Z68 gen3 extreme7
    CPU : Intel Core i7 2600k (stock for the moment)
    CPU Cooler : Corsair H80 sealed loop water cooling kit
    RAM : 4x4GB Corsair Vengeance 1600Mhz class 8
    Vid card : 2x EVGA GTX 570 Superclocked
    PSU : Corsair HX1000
    ODD : Blu-ray drive LITE-On iHOS104-08
    HDD :
    1x WD Velociraptor 10000RPM 600GB
    2x WD Black 2TB WD2002FAEX
    SSD :
    1x OCZ Vertex 3 240GB MAX IOPS (boot drive)
    1x Patriot Pyro 120GB (40gb used as cache (SRT) for Velociraptor, 60GB usable, not setup yet)
    1x OCZ Vertex 120GB
    Monitor : DELL WFP3007 30" 2560x1600
    Keyboard : Logitech G510
    Mouse : Razer Lachesis
    Case : Fractal Design Define XL with Noctua fans everywhere

  2. #2
    Join Date
    Oct 2011
    Location
    QC, Canada
    Posts
    20

    Default Re: Various problems with ASRock Z68 GEN3 extreme7

    Alright, so I had time to update the BIOS to version 1.30.

    Issue #1 has been solved by the update

    Issue #2 still exists, I have to revert to an older keyboard to get to the BIOS

    Issue #3 is slightly better now but still longer than I expected, most likely because I finished the installation and it doesn't have to rescan and update the hardware everytime it boots but I still have a good 20-30s without any display, followed by 1 splash screen, 1 raid config and then another splashscreen before it starts booting windows.

    Issue #5, the vid cards are detected properly now, the drivers are installed and the cards are running in SLI. Didn't have the time to install games so I didn't test it further.

    Issue #6, didn't play with the RAM timings yet, wanted to finish the updates, etc. and then backup before messing with it and the OC.

    So overall, things are much better now than yesterday but it's not fully resolved.

    Oh and shameless bump :P

  3. #3
    Join Date
    Mar 2011
    Location
    Taiwan
    Posts
    562

    Default Re: Various problems with ASRock Z68 GEN3 extreme7

    Dear Kerdal,

    Please kindly provide your e-mail for me, I will send a special BIOS to you for testing.

    Thanks!

    Have a nice day
    ASRock TSD
    Emily

  4. #4
    Join Date
    Oct 2011
    Location
    QC, Canada
    Posts
    20

    Default Re: Various problems with ASRock Z68 GEN3 extreme7

    Emily, I sent the email address via private message.

    Another small update, tried OC'ing the cpu (I started with a mild OC to 4.0GHz) and adjusting the RAM timings (to their specs, 1600Mhz 8-8-8-24). Everything went smoothly on the first try and it's stable. Overall, I'm pretty satisfied.

  5. #5
    Join Date
    Oct 2011
    Location
    NYC
    Posts
    6

    Default Re: Various problems with ASRock Z68 GEN3 extreme7

    I've just been setting up mine in the last two days, too. I think the long post occurs when USB devices are hooked up. I remember having only my PS2 keyboard hooked up (through the included rear adapter) when I was booting and installing windows. It was a very fast post.

    When you OC'd, did you just bump it to 40x? I just bumped from 33x on my 2500k to 38x without making any other changes and it tested stable on a max IBT test for about 25 minutes. Will do more testing, of course. Hoping to hit 4.5.

  6. #6
    Join Date
    Oct 2011
    Location
    QC, Canada
    Posts
    20

    Default Re: Various problems with ASRock Z68 GEN3 extreme7

    To be honest, I used the built-in profile and it worked well. I may fine tune it later but it's stable so that's the important part. I noticed that it bumped the multiplier to 40x and it bumped something else to 150 (not the BCLK). I'm not yet familiar with OC'ing the i5/i7 because my previous cpu was a Q9550 which relied on the good old FSB OC.

  7. #7
    Join Date
    Oct 2011
    Location
    italy
    Posts
    4

    Default Re: Various problems with ASRock Z68 GEN3 extreme7

    Same problem with logitech g510 on UEFI

  8. #8
    Join Date
    Mar 2011
    Location
    Taiwan
    Posts
    562

    Default Re: Various problems with ASRock Z68 GEN3 extreme7

    Dear gabryangeli,

    Due to we don't have Logitech G510 keyboard, we buy the keyboard from Europe at the present.

    As soon as we get the keyboard, we will test the issue and update to you.

    Pleases kindly provide your e-mail and model name for me.

    Thanks for your help.

    Have a nice day
    ASRock TSD
    Emily

  9. #9
    Join Date
    Oct 2011
    Location
    italy
    Posts
    4

    Default Re: Various problems with ASRock Z68 GEN3 extreme7

    any news?

  10. #10
    Join Date
    Oct 2011
    Location
    italy
    Posts
    4

    Default Re: Various problems with ASRock Z68 GEN3 extreme7

    up

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •