Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 3 of 3

Thread: Power Surge on USB Hub - Fault with Asrock board?




  1. #1
    Join Date
    Sep 2011
    Location
    UK
    Posts
    9

    Default Power Surge on USB Hub - Fault with Asrock board?

    Why do I keep getting this message about a power surge on USB Hub? Is this a fault with the Asrock motherboard or something else?
    http://i41.photobucket.com/albums/e2...m/P1030522.jpg

    I have the Extreme4 Gen3 board.

    It keeps happening even if I only have the wireless keyboard and mouse connected on the USB port at the back of my pc. When it happens the screen completely freezes and my keyboard and mouse stop working. There is absolutely nothing I can do except hit the reset button.

    Any help or advice with this would be greatly appreciated. I have a suspicion that it could be the Asrock software XFastLan utility that I have previously question how to get rid of (circled in red)
    http://i41.photobucket.com/albums/e2...an_Monitor.jpg

    Do you think it could be that causing the problems? I believe it's meant to be able to enhance the speed of standard USB devices to try and increase to their maximum available throughput for that type/version of USB and maintain consistent high speed? That's the impression I get anyway of what it is meant to do. The utility just annoys me because I don't know how to prevent it from showing on my desktop or how to hide or disable it.

    I don't understand how it could possibly be a power surge because USB is just 5 volts is it not? And it can't be too many devices connected especially if I only have one device a wireless usb keyboard and mouse, besides which you're meant to be able to daisy chain hundreds of USB products.

    Thanks for any advice,

    John

  2. #2
    Join Date
    Sep 2011
    Location
    UK
    Posts
    9

    Default Re: Power Surge on USB Hub - Fault with Asrock board?

    I have uninstalled the Asrock XFastLan and XFastUSB/cFosSpeed Status utilities to see if this makes a difference. I suspect that could be one likely cause.

    Will keep you updated how I go on.

  3. #3
    Join Date
    Sep 2011
    Location
    UK
    Posts
    9

    Default Re: Power Surge on USB Hub - Fault with Asrock board?

    Well I have ruled out the Asrock XFastLan and XFastUSB/cFosSpeed utility programs. I am still getting power surge on USB hub so AFAIK it can now be only one of two things. It has to either be a faulty Asrock board or faulty power supply. I am not favouring psu because the usb ports are only 5 volts anyway and I just don't see how that could be the case so I am going 60/40 on it being a faulty mainboard.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •