Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 6 of 6

Thread: Help! Pair of G41MH/USB3 R2.0 unusable for Bios 1.20 faults

  1. #1
    Join Date
    Oct 2011
    Milan, Italy

    Default Help! Pair of G41MH/USB3 R2.0 unusable for Bios 1.20 faults

    first, I apologize for the slowness, but I think the problem may affect all unlucky buyers of this motherboard.
    I would be also sorry to see my post, for obvious marketing reasons, censored / banned simply as RMA question.

    Satisfied with previous purchases of ASRock motherboards and attracted by the unique features, I bought a pair of G41MH/USB3 R2.0 to update two cheap stations at my office.

    These configurations:
    - 2 x PSU Corsair Builder Series CX430 V2 430W
    - 2 x Intel Pentium Dual Core E6700 3.20GHz
    - 2 x 4GB RAM Kingston KVR1333D3N9K2/4G 1333 (2x2GB) CL9 1.5V
    - 1 x HD Seagate ST31000528AS 1TB
    - 1 x HD Samsung SpinPoint F3 HD502HJ 500GB

    Assembled the first PC, I access the BIOS to set system time and date.
    Strangely, the CPU is recognized but the speed is 1600 MHz and the ratio is locked at 6.
    Many configuration parameters aren't accessible, such as Intel SpeedStep, the CDROM is not showed, etc..
    Obviously, I decide to load BIOS Defaults and try again. The behavior of the BIOS is still random: CPU Ratio = 8, SpeedStep has become accessible and set to Auto, but the cdrom is viewed as a Tape.
    I try to reset CMOS with the jumpers on the board, to take away CR2032 battery, replace the RAM, to boot into single channel. Nothing, the behavior of the BIOS every time I reboot is random.
    At one of the repeated reboots, ASRock Instant Flash becomes available, so I decide to download the BIOS 1.20 from the support site and try to reflash it.
    Success !! But the cdrom is still recognized as Tape, so I reload BIOS Defaults.
    (Of all these ups and downs, I wrote to the Technical Support Division ASRock on 26 september without receiving any response until now)
    At last everything is recognized and seems to have returned to normal. I try to load the operating system, but the system hangs on the BIOS screens logo. Further reboots and I can also install Windows XP.
    Eureka! Memtest+ OK, hours of stress with a Linx 36 C idle, 58 C max. I can still, I've got it.

    I assemble the second PC. Same problems of random behavior of the Bios !!!
    I begin to worry again, if it persists on two motherboards the fault is systemic.
    After the same pain, including the reflash of BIOS, even this time I can install the OS on the second PC.

    Was my illusion, after a few days the first PC unexpectedly starts to shut down during use, but all appears normal to restart.
    Then the OS fails to power down, the fans remain on and I have to take action with the case reset switch.
    Spend the other days. Epilogue, the first PC display BSoD: STOP: 0x000000A5 .......The ACPI Bios in this system is not fully compliant to the specification. ...etc.
    I tried to bring the hal.dll to standard PC, but nothing to make.
    The routine with ASRock Instant Flash apparently is successful, but now brings no effect. The downloadable update file exe by Dos (in fact Afudos 4.33) is a joke, because it stops showing bios write protect.
    As a last test I tried the Live Ubuntu 10.4 LTS, but the kernel compilation stops at the first screen showing an endless array of errors and inconsistencies.
    If that's the way it is, I can only expect a very short time the same BSoD to the second PC.

    Any help with this will be greatly appreciated.

    Thanks in advance.

  2. #2
    Join Date
    Nov 2011

    Unhappy Re: Help! Pair of G41MH/USB3 R2.0 unusable for Bios 1.20 faults

    Sorry, can't help you.. But I can tell you that you're not alone, I have the same experience.

    I bought a G41MH/USB3 R2.0 for my cousin's computer, for a couple of days everything was well, but then strange things started to happen: Computer suddenly wouldn't boot (Windows would appear to load very slowly, then bluescreen and instantly reboot.. Same thing happens for both SATA and IDE, can't even access XP Safe mode). Also, suddenly all possibilities of USB boot disappeared from BIOS.. If I boot a live Linux distro from CD (for some reason this only works if I disconnect my hard drive) my USB mouse will work, but the cursor moves very slowly and choppily.

    I tried reflashing the only existing BIOS version (1.20) using floppy and Instant Flash (couldn't use USB stick because it's not recognized in BIOS, and couldn't use DOS flash because it says BIOS is write protected) but problems persist, they just change shape. Depending on what I do the BIOS appears to perform pretty randomly, sometimes things are greyed out and sometimes not. The system is unusable. I will RMA the board, but I fear I will only receive an identical piece in return.

    Edit: Other system components:

    Fortron/Source 350 W ATX 2 compliant power supply, also tried another power supply
    Intel Core 2 Duo E6420, also tried a 2.93 GHz Pentium 4.. Temperatures OK
    LeadTek GeForce 6600 (also tried with integrated Intel graphics, same result)
    1x2 gigs of Kingston ValueRAM (KVR1333D3N9/2G, passes MemTest86+)
    Tried both Seagate Barracuda SATA (7200.7, 200 gigabytes) and ATA (ST320430A, 20 gigabytes) hard drives
    Various ATA DVD drives, also tried without these of course
    Last edited by paxmir; 11-12-2011 at 04:53 AM. Reason: Neatified, info added.

  3. #3
    Join Date
    Oct 2011
    Florida, USA

    Default Re: Help! Pair of G41MH/USB3 R2.0 unusable for Bios 1.20 faults

    Have you tried just i stick of RAM - try each stick in each slot?
    Also make sure the RAM voltage is at Kingston's recommended 1.5V.

    My HTPC -

    ASRock 970 Extreme3
    AMD FX-4100 w/Coolermaster GeminII S cooler
    M Station HT-1100 HTPC Media Center case
    Antec 480 NeoPower PSU
    Kingston HyperX Blu 8GB KHX1600C9D3B1K2/8GX
    Gigabyte GV-R467ZL 4670/1GB video card
    Hitachi HDS721050CLA362 500GB SATA hd
    Windows7 Ultimate x64 & Ubuntu 10.04 LTS (partitioned)
    Pioneer DVR-215D SATA DVD burner
    Samsung 40" 1080p 120Hz LCD HDTV LN40C630

    You can teach an old dog; it just takes longer.

  4. #4
    Join Date
    Nov 2011

    Default Re: Help! Pair of G41MH/USB3 R2.0 unusable for Bios 1.20 faults

    Hi, I'm sure we've both tried all memory arrangements, but thanks for the RAM voltage tip, the default indeed seemed to be 1.7V instead of 1.5V. Still, changing this did not cure the problem.

    I myself am now stuck at a point where Windows XP will install or start ONLY using a non-ACPI HAL (otherwise I get the "The ACPI BIOS in this system is not fully compliant" bluescreen mentioned above). Also, all USB boot options are missing from my BIOS and F11 menus. Mind you, I was happily USB booting and using an ACPI HAL for many days, before the board very suddenly decided to shed this functionality. In addition to the OP, a similar story can also be found at a German forum here - the guy tried multiple PSU's, RAM sticks and CPU's, to no avail... I wonder if this is a case of a bad batch, or something.

  5. #5
    Join Date
    Oct 2011
    Milan, Italy

    Default Re: Help! Pair of G41MH/USB3 R2.0 unusable for Bios 1.20 faults

    Hi, first of all I thank Paxmir for his funny words of grief in the unlucky shared fate with this motherboard.
    I also thank the member Electric bill, but as I already described when opened this thread, I had also tried to boot into single channel.
    Besides, as correctly said Paxmir the BIOS default RAM voltage is 1.7V instead of 1.5V, but changing this did not cure the problem.

    After three weeks and about 780 post readings without replies, adding the access to the corresponding thread simultaneously opened at OCWORKBENCH, in truth I had lost interest in solving once and for all the problem, this because each hour subtracted to my professional activity overcomes the motherboards value and at last I are still convinced that a RMA would produce only the return of a piece with the same problems.

    Following a reminder, Asrock sent me the answer I quote:
    Dear Claudio,
    Thank you for contacting ASRock.
    Please kindly re-install CPU to try.
    If possible, please try another CPU to verify.
    If the symptom still, please contact your dealer to check the board phisically.
    Sorry for the inconvenience.
    Thanks for your e-mail.
    Good Day,
    ASRock TSD

    The proposed solution is very hasty and only time-wasting, I am not a motherboards manufacturer, but after almost twenty years of experience in assembling I exclude that this could happen to two processors and two boards at the same time (worked hours under LinX).

    Against common sense I mentioned just above, I equally spent much time with the motherboard debug being able to eliminate the ACPI problem (Windows BSoD) and to obtain temporarily stable running.

    Unfortunately these days are very busy because of work, be careful be continued....

  6. #6
    Join Date
    Oct 2011
    Milan, Italy

    Default Re: Help! Pair of G41MH/USB3 R2.0 unusable for Bios 1.20 faults

    Hi, I'm back. I will introduce to paragraphs various problems encountered and solutions found.

    Proper warning:
    Remember you are using this information entirely at your own risk. The information presented may not work for you. If you are uncomfortable modifying BIOS or Firmware and flashing them, do not attempt to modify them. You must be able to recover from a "bad" flash.

    PSU incompatibility

    This is the last issue I found, but I put it in first place because a sudden shutdown during the procedures described below may be fatal.
    I became aware of this occurrence accidentally because I had done all debugging at home with a very very cheap Oem PSU.
    Everything worked perfectly, but when I powered the motherboard with Corsair 430CX V2 the sudden shutdowns during use and the OS (Windows all) inability to power down the computer are both here. Same failures with various Linux live CD. I thought it might be the Montezuma's revenge.

    None of this, it all happens because G41MH/USB3 r 2.0 is really picky regarding "Power good signal" and "Power on".
    The PSU is sending the "Power good" to the motherboard, where it is received by the processor timer chip that controls the CPU reset line, if this signal goes down during use, the CPU will shut down. This explains the sudden shutdowns and subsequent re-boots. The nominal voltage of the Power Good signal is +5 V, but in practice the allowable range should be usually up to a full volt above or below that value.

    Instead of using a physical switch, the computer are power down by a signal from the motherboard telling the PSU what to do. In turn, the motherboard can be told to change this signal under software control. This is what allows OS to power down the PC. This feature is called "Soft Power" and the signal that controls the PSU is called "Power On". This explains the all OS inability to power down the computer.
    This signal, called "+5 V Standby", is the same output level as the regular +5 V lines from the power supply.

    The motherboard ran rock stable with a poor Oem PSU, while it creates all the problems described with noble Corsair PSU.

    So ASRock and Corsair share the incompatibility responsibility. On the web I found others who have had the same problems with this Corsair PSU with different motherboards. For its part, on 11/14/2011 ASRock has released BIOS update for motherboards G41-VS3 and G41M-VS3 R2.0 to solve specifically "system can not shutdown issue".

    Given that all ASRock G41 family motherboards share all ACPI Tables, except of course the XSDT and the DSDT (@ 0x004783D0 common base) then overridden and replaced with the DSDT for the specific model, I hope that soon this correction can also be inserted for the model USB3.

    Note the occurrence of these problems of stability or shutdown irrespective of OS is the true test of incompatibility with the PSU, likewise to anybody must come to mind to resolve this issue by installing the bios updates which I said just above.

    ACPI issue - BSoD: STOP: 0x000000A5 .......The ACPI Bios in this system is not fully compliant to the specification

    This was a nasty tough nuts because from the beginning I fixed my attention solely on Bios file G41USB31.20, apart from the hardware on the motherboard.
    So I extracted the module 10, i.e. ACPIaml, from bios and lost a lot of time doing debugging with ACPICA software (iasl.exe, acpiexec.exe at different levels, etc.) without finding never actually no problem with. When I have reconsidered the installed hardware, methought here that the fact that the system could not enter ACPI mode, more precisely occurred "SCI_EN never becomes set in PM1 Control Register", would depend on the ASM1042 chip or better from its firmware. At this point, rather than seek a delicate and complicated fix to acpi_enable/acpi_disable commands inside the bios, I tried on the firmware chip USB3 (aka ASM 1042).

    After a number of trials and research, SOLVED !!!. Flashing firmware 110315_01_02_30.bin on ASM1042 the motherboard resurrects and "ACPI issue - BSoD: STOP: 0x000000A5 .......The ACPI Bios in this system is not fully compliant to the specification" disappear.
    In practice there is nothing difficult, though I recommend to flash firmware by Dos using a floppy drive because the full functionality of USB ports may be compromised. At this link you can find the drivers you need: ASMEDIA drivers & firmwares.

    At firmwares download exclusively "Version 110315/010230 Pour Windows XP/Vista/7 32/64bits".
    Unzip this file, inside the folder FW0315 you will find: 104xFW.CFG, 104xfwdl.exe, 0315_123.bin, d.bat, DOS4GW.exe, readme. test, u.bat.
    Make a DOS bootable floppy disk, then copy to floppy thus obtained the FW0315 folder contents and check the motherboard Bios the floppy is set as 1st boot drive.
    Once you start the computer from Dos, the syntax prompt is very simple: u.bat start the flashing, with d.bat then you can check the content coincides. In any case make the flashing. At this point Windows already installed, or a clean install, should no longer show ACPI issue.

    To the most careful you will not be escaped that to the link Driver station brings further download, do not attract the last firmware Version 110914 believing to do better because it is more up to date, the motherboard would only be brought under the same conditions of ACPI issue.
    A brief reference to drivers, it seems that the version is the best, the later editions work but exhibit problems in energy management by power down disks USB3 linked.

    About driver installation Asmedia USB3

    After the ASM1042 firmware flashing described above, restored the correct Windows startup, it would be better to clean the operating system from all Asmedia USB3 drivers previously installed.
    In "safe mode" or from a Linux live CD find and delete all the following files: asmthub3.sys,, asmthub3.inf, asmtxhci.sys, and asmtxhci.inf.
    Delete from the Programs Asmedia folder. Clean then the registry with CCleaner or Wise registry cleanear. For the more experienced you can also do a search for "Asmedia" and "asm" opening regedit.
    Clean so the operating system, repeat "Intel infinst_autol.exe Version" in order to eliminate any corruption other USB system driver.
    The Asmedia installer doesn't seem to work properly, if used to uninstall can corrupt other usb hub making them inaccessible. During installation however sometimes fails to install its usb hub. Check in Device Manager if there is the notorious yellow question mark, if you manually install usb hub by directing to the unziped folder where the Asmedia driver install utility.

    Bios flashing tool

    The DOS utility stops showing bios write protect. If you want to make an effective flash you can use Flashrom, a Linux utility.
    The easiest way is to download a live Linux reduced as "pmagic-11.11.11", link: downloads.
    I recommend the iso pmagis-i486 to avoid any problems. Mastered the CD, set CD drive as the 1st boot, the usage is very intuitive.
    By clicking on the taskbar LX-terminal, will open the command prompt.

    Just type Flashrom and click send, recognized the Bios chip. Typing Flashrom-h, showing the help commands. The syntax is really intuitive.
    Using File manager on your desktop pmagic Linux live, copy the file G41USB31.20 from a Usb stick to /root. For verification you can first run the command Flashrom-r old.rom, that reads and saves the bios installed.
    The file G41USB31.20 must be copied in the same folder /root where you will find old.rom.

    In summary, in order: flashrom-E (uppercase!) will clear the bios chip, flashrom-w G41USB31.20 will write the bios chip, flashrom-v G41USB31.20 to verify correct writing. Caution it is normal that is extremely fast. Do not turn off if not appears the inscription VERIFIED !!

    Closed pmagic Linux live, before the reboot Clear CMOS by Jumper for 15-30 seconds according to the instructions of the manual.
    To restart set system time and date only, before you save and exit load Bios default strictly, this is crucial: only in this way next time the motherboard properly recognize the installed hardware, otherwise the behavior is random.

    The next reboot all hardware should be recognized correctly, now you can enter your bios preferences and simply save and exit.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts