Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Asrock Z68 Pro3 - No Video Output From/Will Not Recognise Sapphire ATI 6950 Gfx Card




  1. #1
    Join Date
    Nov 2011
    Location
    United Kingdom
    Posts
    6

    Default Asrock Z68 Pro3 - No Video Output From/Will Not Recognise Sapphire ATI 6950 Gfx Card

    Hello Tweaktown members - hoping for a little help with a problem I've been trying to solve all night :S

    Just bought a new Sapphire Radeon HD6950 2GB card to replace the current Radeon HD4890 I was using and for some reason it is not recognised by my Z68 Pro3 motherboard. Fans turn on, computer passes POST and boots into windows but I just get no video output. Internal graphics work fine and re-installing the HD4890 also works fine.

    I have tried the HD6950 in another intel motherboard I have (ASUS P5B) as well as a friends ASUS P5N32-E SLI PLUS and it works fine so am sure the card is 100% ok. I have also tested with a more powerful Corsair AX750 to make sure it wasn't power issue - just seems to be a compatibility issue?

    My setup:

    Asrock Z68 Pro3
    Intel Core-i5 2500k (not overclocked)
    4GB G-Skills Ripjaw RAM 9-9-9-24, 1600Mhz 1.5V
    Sapphire Radeon HD6950 2GB
    Corsair HX520 (520W).

    Appreciate any help and happy to test any beta BIOS etc that might help resolve this as the graphics card is a 200 paperweight whilst I still have this issue :(

  2. #2
    Join Date
    Oct 2011
    Location
    Virginia
    Posts
    17

    Default Re: Asrock Z68 Pro3 - No Video Output From/Will Not Recognise Sapphire ATI 6950 Gfx C

    Did you enter BIOS , and set your primary graphic to PCI Express ? And you have the card in the first PCI Express slot ? Seated well and locked in ?

  3. #3
    Join Date
    Nov 2011
    Location
    United Kingdom
    Posts
    6

    Default Re: Asrock Z68 Pro3 - No Video Output From/Will Not Recognise Sapphire ATI 6950 Gfx C

    Hi there Blackhawxlh, gfx priority set to PCI-E, Shared IGP memory set to auto, IGP multi display disabled.

    I've tried just about every iteration on the northbridge configuration screen without success, it just doesn't seem to see the card is installed as it simply doesn't output video or appear in the device manager in windows (plugging a DVI cable into the internal gfx connections will work even if PCI-E is set to primary and PCI-e card is installed.)

    I'm guessing the reason it can still boot into windows with the 6950 installed is because the card isn't detected on POST and it switches to internal graphics as a contingency.

    Any more suggestions are completely welcomed!! :S

  4. #4
    Join Date
    Oct 2011
    Location
    Virginia
    Posts
    17

    Default Re: Asrock Z68 Pro3 - No Video Output From/Will Not Recognise Sapphire ATI 6950 Gfx C

    Sry your having so much troubles !! I've got some weird one that support is working on as well,...my first Asrock mobo. Very finicky on graphics I'm finding out !! Anyway, lets try this,...if you have'nt already, have you tried a HDMI cable from your video card to your monitor ? The reason I ask is just to try another output source from the card ! Also get DriverSweeper a free app. the you can use in safe mode to wipe out all of the Ati drivers and do a clean install , while your in safe mode install the latest drivers !! Also the HD6950 is a power hog, so I think the main problem your running into is your power supply is under rated for this card , .... you need at least a 750 Watt pwr sup with at least 30 amps on the 12 volt rails !!! I now believe this to be your trouble !! Can you get another pwr supply to try ?? Also you can cet one from Microcenter.com and if that does'nt do it you have 30 day to return it, but I truly believe this is you problem !! Let me know !! Take a look at this link for further recommendations . http://www.guru3d.com/article/radeon...6970-review/11
    Last edited by blackhawkxlh; 11-04-2011 at 06:10 PM.

  5. #5
    Join Date
    Nov 2011
    Location
    United Kingdom
    Posts
    6

    Default Re: Asrock Z68 Pro3 - No Video Output From/Will Not Recognise Sapphire ATI 6950 Gfx C

    Thanks for your efforts on helping with this. Unfortunately the reason why I was working on this for so long last night was because I was swapping various pieces of hardware to eliminate the possible causes.

    The Corsair 520W supply I have is certified by ATI as working for this card, to be sure though I have tried it with a Corsair AX750 (750W) PSU and it still didn't work yet it works with both PSU's when I use the ASUS motherboard. My XFX 4890 OC Editiion has the same power requirements as the 6950 yet it boots fine and is completely stable so I think I have eliminated power as a cause.

    Unfortunately this isn't a driver issue as it isn't even detected at post, before windows is loaded. I can't even use the computer unless I am using the onboard GPU.

    I tried using the HDMI slot and connecting to my lcd TV and there was no output still unfortunately. I don't have any compatible display device to check the DP port.

    Bottom line is, if I plug it into my ASUS mobo with 1 stick of RAM, CPU, either 520 or 750W PSU and no drives it works. Using the same configuration but just swapping the mobo to the ASRock it doesn't work regardless of BIOS settings, updating to latest 1.6 BIOS and clearing the CMOS etc.

    It's a real shame as the mobo is perfect otherwise!

  6. #6
    Join Date
    Nov 2011
    Location
    United Kingdom
    Posts
    6

    Default Re: Asrock Z68 Pro3 - No Video Output From/Will Not Recognise Sapphire ATI 6950 Gfx C

    I've seen that some people on the forum have had a little luck sorting some problems out with a beta BIOS.

    Am I able to get a copy of this to try?

  7. #7
    Join Date
    Nov 2011
    Location
    United Kingdom
    Posts
    6

    Default Re: Asrock Z68 Pro3 - No Video Output From/Will Not Recognise Sapphire ATI 6950 Gfx C

    Right, decided that I'm going to get a new motherboard tomorrow morning if I dont get thos one working by then.

    I'd like to give the beta BIOS a try before giving up on this though so if anyone can send me it that would be massively appreciated!

    Kind regards.
    Lee.

  8. #8
    Join Date
    Aug 2009
    Location
    Birmingham,Great Britain
    Posts
    9,250

    Default Re: Asrock Z68 Pro3 - No Video Output From/Will Not Recognise Sapphire ATI 6950 Gfx C

    pm emily for a beta bios to try,have you tried reflashing the bios but untick "keep dmi pool data" just before you flash? it might help in detecting your gpu,howmany pci-e slots do you have? tried it in another slot to rule out dead/faulty pci-e slot?
    Gigabyte z77x UP4-TH F11c Modded Bios
    Intel i7 3770k 24/7@4.8ghz 1.38v Turbo llc +0.165v dvid multithreading enabled
    Samsung Green(MV-3V4G3D/US) 8GB @2133mhz 9-10-10-21-1t 1.55v
    Thermalright Silver Arrow Cpu Cooler
    1xSamsung 840 pro 256 Gb SSD windows 8.1 pro 64bit
    1xSamsung f4 HD204UI 2tb hard drive Storage
    Powercolor 7970 3gb V3 @1150mhz core/1700mhz mem,1.150v Accelero aftermarket air cooler 55c max
    Razer Lycosa Keyboard
    Logitech X-530 5.1 Speakers
    Lite-On iHAS124-19 24x Sata DVDRW
    K-World Hybrid DVB-T 210SE Digital T.V Card
    L.G E2260V L.E.D 1920x1080 Monitor
    Xfx Pro 750w silver rated Psu 80+
    Fractal Arc Midi Case

    http://i38.tinypic.com/14myvfa.jpg x58 ud5 <=3.8ghz + 4.2ghz Overclock Template!!
    http://www.youtube.com/user/warren304#p/u Visit Me On Youtube

    Lots Of Gaming Videos With X58 Ud5 System And Gpu On My Youtube Channel!!
    Just Uploaded New Battlefield 4 Video!!!!!!!!!!!!!!!!!!!!!!

  9. #9
    Join Date
    Oct 2011
    Location
    Virginia
    Posts
    17

    Default Re: Asrock Z68 Pro3 - No Video Output From/Will Not Recognise Sapphire ATI 6950 Gfx C

    He's right,....I took his suggestion and did that and my problem that I had is now solved !! Sry for getting back to you so late my brother, but I'll tell you this, my problem was solved with a simple BIOS reset to defaults . Not sure if this will solve yours, but I know this....it just saved my but from wiping , and reformatting my C drive and starting over and having to put all my programs and stuff back in !!! Might be worth a try !! Hope this helps !! If not,... for sure contact Emily, shes real good and very polite to work with , unlike others that I tried to get help from..... wazza300 excluded !! Good luck, and let me know how you make out !! Blackhawk

  10. #10
    Join Date
    Nov 2011
    Location
    United Kingdom
    Posts
    6

    Default Re: Asrock Z68 Pro3 - No Video Output From/Will Not Recognise Sapphire ATI 6950 Gfx C

    Wanted to make sure I replied the outcome on here as I hate it when a thread goes stale before the solution was posted!

    Turns out the graphics card is the problem as I bought an MSI P67A-GD53 motherboard today and the same problem occurred. Really weird as it still works if I put it in the much older ASUS board.
    My fired has the same 6950 gfx card so I asked if I could fit it to his rig and it didn't work either (1 long beep 2 short = video card issue) so it's definitely the card.

    Thanks for everyone kindly trying to assist.

    Regards
    Lee.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •