Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: Z68 Pro Gen3 No Display on startup




  1. #1
    Join Date
    Nov 2011
    Location
    California
    Posts
    1

    Default Z68 Pro Gen3 No Display on startup

    i5-2500k
    Memory: Corsair Vengeance/Mushkin Redline/Kingston HyperX(Supported by Mobo)
    Corsair 750w PS
    WD HDD
    Blu Ray drive
    HIS IceQ 6950


    So far I've
    - Made sure everything is connected right. (tried with the HDD/Blu Ray unplugged).
    - Tested 1 ram stick (of every brand) on every slot (slot 2 gives memory error 30 with the Kingston, they all give error code 45 otherwise).
    - Reseated the CPU multiple times (no damage- unless the little dents the pins make are damage or bent pins in the socket)
    - Multiple monitors, both VGA and HDMI into both the video card and the motherboard.
    - Resetting the CMOS
    - Replacing the motherboard/CPU with new ones.

    There might be a few other things I'm forgetting, but it's been 2 weeks of trying to get a display up and going. I checked other posts on the forums and the only suggestion I found I haven't tried is changing the 8pin connector from the power supply, but I don't know how to do that, since there's only one 8pin connector.

    More information: I also had the same no display on startup from an ASUS board, when I tried to use a different board. I don't know if this helps.
    More information: Tried a different power supply (800W Cooler Master), no change. I'm still getting error 45 (30 on slot 2)

    Any help would be greatly appreciated.
    Last edited by omni; 11-19-2011 at 01:21 AM.

  2. #2
    Join Date
    Dec 2011
    Location
    California
    Posts
    1

    Default Re: Z68 Pro Gen3 No Display on startup

    RMA your board now.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •