Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 3 of 3

Thread: ASRock Z68 Extreme4 Gen3, pci soundcard not working.. On-board sound works fine.




  1. #1
    Join Date
    Nov 2011
    Location
    Singapore
    Posts
    1

    Default ASRock Z68 Extreme4 Gen3, pci soundcard not working.. On-board sound works fine.

    Hey guys, just built my rig yesterday. I'm on Windows 7 64.

    I'm using the razer barracuda AC-1 soundcard, tried all kinds of drivers, disabled onboard audio, reseated my card, but audio still doesn't work!

    The equalizers are moving when I went to test for sound from the control panel but it still doesnt work, regardless of where I plug my aux cable to, rear panel onto the card or front panel headphone jack.

    Any other idea on how I can troubleshoot this? I'm at a loss!

    Thanks for your help

  2. #2
    Join Date
    Mar 2011
    Location
    Taiwan
    Posts
    562

    Default Re: ASRock Z68 Extreme4 Gen3, pci soundcard not working.. On-board sound works fine.

    Dear TheKid,

    Due to we don't have Razer Barracuda AC-1 sound card, we test Creative sound card SB0770 PCI sound card and the card can work normally with BIOS P1.00 and P1.10.

    Please kindly provide below suggestions for the user to try.
    1. Update the latest BIOS P1.10 from below link to try.
    Link: ASRock > Products > Motherboard > Z68 Extreme4 Gen3 > Download
    2. Please kindly check whether the sound card can be recognized by system in device manager or not.
    3. Install your sound to another PCI slot to try.
    4. If possible, please kindly install the sound card to other system to check whether the sound card is fine.
    5. If possible, please kindly install other sound card to check whether the symptom still occur.

    If the problem still cannot be solved, please kindly contact your local dealer for assistance.
    Thanks~

    Have a nice day
    ASRock TSD
    Emily

  3. #3
    Join Date
    May 2011
    Location
    Rudehen, Tehran, Iran
    Posts
    302

    Default Re: ASRock Z68 Extreme4 Gen3, pci soundcard not working.. On-board sound works fine.

    Try this driver:
    C-Media Electronics, Inc. -> CMI8788

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •