Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 6 of 6

Thread: Asrock 990fx Fatal1ty won't power up




  1. #1
    Join Date
    Dec 2011
    Location
    Oklahoma City, Oklahoma, United States
    Posts
    2

    Default Asrock 990fx Fatal1ty won't power up

    Current computer specs:
    Asus CHiv Formula + AMD phenom x6 1090t BE
    G.skil Flares 2x2gb 1800
    corsair SSd GT120 (OS)
    WD velosiraptor 600gb HDD (storage)
    Saphire HD6950 + xfx HD6950 (xfired)
    cougar 850w PSU modular
    corsair 600t black case (before they came out with the new side panels)
    Windows 7 64bit

    Okay this isn't the first time I built a computer but it is the first time I haven't built with all new parts. So here's the problem... I bought the 990fx fatal1ty (bios p1.30) to replace my asus CHiv form. Should I have done a secure wipe of my SSd before I plugged everything into my asrock? My PSU powers everything up on the asus w/o any problems. I plugged everything in last night to the asrock and it worked for about a minute... it went into windows and the computer did a few updates then shut down and now I can't power on the board at all. I know all my parts are good because I plugged everything back into my asus. I've checked all my connections tomake sure they're seated correctly... i'm stumped.

  2. #2
    Join Date
    Dec 2011
    Location
    Oklahoma City, Oklahoma, United States
    Posts
    2

    Default Re: Asrock 990fx Fatal1ty won't power up

    So after some brain storming I decided to take a chance and purchase a tx850m corsair power supply. It turns out the 990fx didn't like that fact that my cougar 850w psu had 4 x 12v rails and wouldn't allow the psu to power on. My board runs w/o flaws (it has p1.30 alrdy loaded). So now to OC and test for stability.

  3. #3
    Join Date
    Oct 2011
    Location
    Florida, USA
    Posts
    88

    Default Re: Asrock 990fx Fatal1ty won't power up

    Thanks for sharing that info & glad you got it sorted out.
    Happy ocing.

    Bill
    My HTPC -

    ASRock 970 Extreme3
    AMD FX-4100 w/Coolermaster GeminII S cooler
    M Station HT-1100 HTPC Media Center case
    Antec 480 NeoPower PSU
    Kingston HyperX Blu 8GB KHX1600C9D3B1K2/8GX
    Gigabyte GV-R467ZL 4670/1GB video card
    Hitachi HDS721050CLA362 500GB SATA hd
    Windows7 Ultimate x64 & Ubuntu 10.04 LTS (partitioned)
    Pioneer DVR-215D SATA DVD burner
    Samsung 40" 1080p 120Hz LCD HDTV LN40C630


    You can teach an old dog; it just takes longer.

  4. #4
    Join Date
    Dec 2011
    Location
    easton
    Posts
    1

    Default Re: Asrock 990fx Fatal1ty won't power up

    So i have a Xpower1080 800w power supply and my board doesn't seem to power up. I'm not sure what you meant by "it did not like...[your old power supply]". Can you help me out? The only thing I got working was the LED on the board to display "19" and 3 long beeps. I looked at the manual and it told me to install RAM. So after I installed the RAM I get nothing not even a power supply spin up/glow.

    Thanks.

  5. #5
    Join Date
    Oct 2011
    Location
    Australia
    Posts
    40

    Default Re: Asrock 990fx Fatal1ty won't power up

    Check motherboard manual.

    And FYI, no PSU under 1000w has a true multi rail design. So the board musn't have liked the PSU for a different reason (or maybe it just died). And Cougar is not a quality brand and probably not up to latest or even recent ATX spec.
    My Rig
    CPU: Phenom II X4 955BE @ 4GHz
    RAD: Corsair H60 [2x Gentle Typhoon AP-15]
    MB: ASRock 990FX Fatal1ty Professional
    RAM: 8GB G.Skill Ripjaws X 1600MHz
    GPU: MSI GTX 560 Ti Twin Frozr II OC
    SND: Asus Xonar Essence STX
    SSD: Cosair Force 3 60GB
    HDD: Samsung F3 1TB
    PSU: Silverstone Strider Plus 600W ST60F-P
    CASE: CoolerMaster Storm Scout

  6. #6
    Join Date
    Dec 2011
    Location
    Indonesia
    Posts
    9

    Default Re: Asrock 990fx Fatal1ty won't power up

    when you replace the motherboard with different brand, even with the same brand but different model, it's very Recommended to re-install your OS. because the driver is different beetwen the motherboard model.
    if you don't want to re-install the OS, just try to remove all motherboard driver, and completely clean use driver cleaner utility on safe mode (ex. Driver Sweeper or CCleaner), than swap with your new motherboard, and install the new driver from new motherboard driver CD.
    good luck.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •