Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: ASrock ion 330 Dead?




  1. #1
    Join Date
    Dec 2011
    Location
    Lithuania
    Posts
    1

    Default ASrock ion 330 Dead?

    Hello people,
    I have this little nettop pc, ASrock ion. After disassembling it and reassembling it i has gone black on me. I plug in the power source, i connect a monitor to vga or hdmi and when i turn the nettop on it does nothing. No bios post no beeps nothing. The hdtv says no signal and thats it. The power button is on as usual, glowing blue, and the little red lamp isnt showing any activity whether hard or cd rom or rams or anything is attached to it or not. Ive become desperate. Fans are turning and thats it. Ive tried reseting cmos, changing th mother boards battery, taking out all the components, always the same result. No bios post no beeps no display, nothing. If anyone can help it would be much appreciated. Ive google for hours and did not found anything effective. Please help. Came here because i found this forum in asrocks page.
    Nettops spec are simple:
    ASrock ion 330
    Nvidia graphic processor
    2 gigs of ram
    DVD RW drive
    300gb hard (which i tested on my regular pc and it works)
    Motherboard has writings: AMCP7A-ION
    Intel atom processor

    Thanks for any help

  2. #2
    Join Date
    Oct 2011
    Location
    U.S.
    Posts
    166

    Default Re: ASrock ion 330 Dead?

    Double-check to make sure that everything is connected as it was before you disassembled it. In other words re-seat all connections to the board. If that fails to get things working try using another PSU just to rule out that that blew up (Murphy's Law) if that does not work. Then it sounds like somewhere in the disassembling and re-assembling that a component(s) was/were fried due to electrostatic damage...
    ASRock™ Z68 Extreme7 Gen3 LGA 1155 Intel Z68 Intel™ Core i7-2600K LGA1155 Corsair™ Hydro Series H100 Extreme Performance Liquid CPU Cooler (CWCH100)
    G.SKILL™ Ripjaws X Series 16GB DDR3 2133 Model F3-17000CL11Q-16GBXL (2) ASUS™ ENGTX560 TI DCII TOP/2DI/1GD5 GeForce GTX 560 Ti in SLi
    OS Drive: Mushkin™ Chronos Deluxe 120 GB SATA 6.0 Gb/s SSD(MKNSSDCR120GB-DX) Storage: 2-Western Digital™ WD2002FAEX 2TB SATA III 7200 RPM 64 MB Cache Hard Drives
    Optical: HP™ Multiformat DVD Writer SATA Model 1260i Plextor™ Blu-ray writer PX-LB950SA Viewsonic™ V3D245 3D LED display @120hz
    PC Power and Cooling™ Silencer Mk II 950W Inwin™ DRAGON RIDER case APC™ BR1500LCD UPS 1500VA w/AVR Win7™ Ultimate 64

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •