Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 6 of 6

Thread: Z68 Extreme7 Gen3 USB 3.0 header for front panel problem




  1. #1
    Join Date
    Jan 2012
    Location
    USA
    Posts
    3

    Default Z68 Extreme7 Gen3 USB 3.0 header for front panel problem

    my MB is Z68 Extreme7 Gen3

    Hello

    I have a problem with USB 3.0 header for front panel. The problem is that one usb port works the other one doesn't. I was thinking may be it's a problem with the port so i replaced a front panel from my case through the company who makes it but the problem still exist. I just tested USB 3.0 front panel which came with motherboard and it's the same problem. Do you think it can be fixed through bios update or it's a problem with motherboard.

    When i plug in USB flash drive to the port which doesn't work the light on a flash drive lights up and nothing happens; when i connect usb portable hard drive even the light on the back of HDD doesn't light up.

    BTW i have Bios L1.32

    Thank you

  2. #2
    Join Date
    Mar 2011
    Location
    Europe
    Posts
    17

    Default Re: Z68 Extreme7 Gen3 USB 3.0 header for front panel problem

    Similar problems exist with other Asrock motherboards, like P67 Extreme4 or Z68 Extreme4 Gen3, but they have different type of USB 3.0 host controller chip, the Etron EJ168A. See this thread:
    asrock extreme 4 gen 3, slow usb 3 speed on front panel.

    Your motherboard has the ASM1402 USB 3.0 host controller. Update the driver for ASM1402 USB 3.0 host controller.

    The rear ports seems to be connected directly to the chipset (P67 or Z68), while the front port is connected through a PLX bridge chip.

    I am wondering if Asrock is capable of providing a reliable USB 3.0 solution...
    Last edited by bat4; 01-14-2012 at 04:02 PM.

  3. #3
    Join Date
    Jan 2012
    Location
    USA
    Posts
    3

    Default Re: Z68 Extreme7 Gen3 USB 3.0 header for front panel problem

    i have ASMedia USB 3.0 driver ver:1.10.1.0 installed

    What are the latest drivers?

    Thank you

  4. #4
    Join Date
    Mar 2011
    Location
    Taiwan
    Posts
    562

    Default Re: Z68 Extreme7 Gen3 USB 3.0 header for front panel problem

    Dear nikony13,

    We didn't see the symptom on our side.

    Please kindly contact your local dealer to check your system.

    Thanks!

    Have a nice day
    ASRock TSD
    Emily

  5. #5
    Join Date
    Jan 2012
    Location
    USA
    Posts
    3

    Default Re: Z68 Extreme7 Gen3 USB 3.0 header for front panel problem

    Quote Originally Posted by ASRock TSD - Emily View Post
    Dear nikony13,

    We didn't see the symptom on our side.

    Please kindly contact your local dealer to check your system.

    Thanks!

    Have a nice day
    ASRock TSD
    Emily
    I don't have a local dealer, i purchased it online

  6. #6
    Join Date
    Jul 2012
    Location
    Bristol, United Kingdom, United Kingdom
    Posts
    1

    Question Re: Z68 Extreme7 Gen3 USB 3.0 header for front panel problem

    I have exactly the same problem with an Asrock Z68 Extreme4 Gen 3. Only one of the front USB 3.0 header ports work.

    This wouldn't be so bad, but has 1 built in USB 3.0 port, and the 20 pin header connects it to the port which doesn't work!

    Did you ever find a solution to the problem?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •