Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 5 of 5

Thread: Need help installing two pcie x1 card on asrock x79 extreme9 mobo




  1. #1
    Join Date
    Jan 2012
    Location
    New York
    Posts
    2

    Unhappy Need help installing two pcie x1 card on asrock x79 extreme9 mobo

    It's driving me crazy. The Asrock X79 extreme9 mobo only has 1 pcie 2.0 x1 expansion slot and I need 2. All the other slots are pcie 3.0 x16. If I install the Gameblaster into the the pcie 2.0 slot, I can't get my Asus PCE-N15 wireless adapter to work which needs the same slot I guess. The reason I say I guess is because Windows won't launch when I place the wireless adapter in any of the other available slots.

    If I install the wireless adapter into the pcie 2.0 slot, it works just fine. But now the Gameblaster soundcard won't work on any of the other slots. So I'm left with at the moment a choice between no internet or no sound.

    Does any know if it's a setting I can change to make it work, or do I have to go buy either a new wireless adapter or a sound card? Currently the only slot I use at the moment is PCIE 3 x16 slot 1 for my EVGA GTX 580 and the PCIE 2.0 x1 for my wireless adapter.

    thanks in advance!

  2. #2

    Default Re: Need help installing two pcie x1 card on asrock x79 extreme9 mobo

    your card has two PCIe x1 slots. You may have to move your video card to the middle PCIe x16.

    also, it sounds like a conflict of addresses. just plug the second card into the motherboard after booting into windows and it should assign it properly. PCIe was designed for servers and they are hot-swappable. Just be careful to keep the card straight.

    you might be able to manually setup cards in the BIOS if that is still an option on motherboards today.

    check to see if there is a newer BIOS for your motherboard as it is very new.

    Luck
    -=Mark=-
    ASRock Z68 Extreme3 Gen3 i7 2600K 8GB (2 x 4GB) G.Skill 1333 CL9 MSI HD 7750 Corsair TX850 80Plus

    GigaByte A75-UD4H AMD A*-3870K 8GB (2X4GB) G.Skill 1866 CL8 On-Chip 6550D Antec EA-450 80Plus Platinum

  3. #3
    Join Date
    Jan 2012
    Location
    New York
    Posts
    2

    Default Re: Need help installing two pcie x1 card on asrock x79 extreme9 mobo

    Thanks, but the Asrock x79 Extreme 9 mobo only has 1 PCIE x1 slot and 5 PCIE x16 slots. Also tried hot swapping the card as you suggested but it only froze my computer. For the life of me I can't find the setting in the Bios for manually setting it as well. The bios I'm running is 1.80 and the next bios update doesn't address this issue.

    Hmmm...beginning to think I made a mistake buying this mobo. I sent an email to Asrock tech support but haven't gotten a response. They seem to take forever answering your questions.

  4. #4
    kick's Avatar
    kick is offline Senior Member
    Join Date
    Feb 2009
    Location
    Europe,the wild wild west.
    Posts
    1,223

    Default Re: Need help installing two pcie x1 card on asrock x79 extreme9 mobo

    The slots and pci 3.0 should be backward compatible?

    Its there an option to turn off pc i3.0 since you have nothing that uses it atm?)

    Anything in the manual that indicates the correct slots for different items? as the above poster said ,is slot 1 the one that you are supposed to use for gx with only 1 card?.I thought I saw a digram somewhere where it should be like slot 2 or 3.

    Since asrock response seems too slow, and if you dont get more replies here, why not check out reviews of the board etc, there must be plenty of them online by now.
    Maybe there would be some info there.

    edit : Thought I saw some advanced northbridge connection window in the uefi that seemed to relate to pci slot usage. Perhaps adjustments are needed there (see manual?)
    You can save uefi screen shots to a usb stick.
    Last edited by kick; 02-01-2012 at 01:15 AM.
    Current Systems:

    Asrock p67 Extreme6.............. Gigabyte EP-45 UD3 ...................... Gigabyte 73 PVM S2
    Intel i5 2500k 4.8ghz................ Intel Q8400 3.8ghz......................... Intel D820 2.8ghz
    Zalman 10x cooler.................... Coolermaster V8............................ HP cooler
    8GB Gskill ripjaw ddr3.............. 4GB Gskill PI ddr2.......................... 4GB samsung ddr2
    60GB ssd/500GB HDD .............. WD 1TB hdd.................................... Seagate 160GB hdd
    GTX 460 1GB x2 SLI ................. Msi 9600GT 512MB(died) ........... Onboard gx
    Win7 64 ,750w psu(ocz)............ Win7 64 ,520w psu,seasonic...... Win XP pro ,400w psu

    HEC 6A34 case . ....................... Jeantec R2 case............................ Packard Bell case

    hoping to upgrade to http://www.thinkgeek.com/stuff/41/habicase.shtml
    http://www.flixya.com/video/140325/Animal-launching

  5. #5
    Join Date
    Feb 2013
    Location
    Russia
    Posts
    1

    Default Re: Need help installing two pcie x1 card on asrock x79 extreme9 mobo

    Hi!

    Were you successful after all?
    I'm thinking of buying this mobo and definitely will have 2 PCIE x1 devices to insert. Wondering if it is possible to use one of PCIE x16 slot for 1 of my PCIE x1 devices.

    Didn't found any info in motherboard's manual as well.

    Thanks!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •