Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 5 of 5

Thread: ASRock z68 Fatality Professional Keyboard/Mouse Problems and Questions!




  1. #1
    Join Date
    Feb 2012
    Location
    USA
    Posts
    5

    Default ASRock z68 Fatality Professional Keyboard/Mouse Problems and Questions!

    I currently just got my new Mobo

    I have everything at stock settings, and nothing is overclocked.

    I have installed Windows 7 Ultimate, GPU Drivers, the motherboard install disc, updated most everything in windows update.

    Currently here are the problems and I have seen others post about these issues on various boards.

    I am trying to use a LOGITECH g110 Gaming Keyboard///RAZER Deathadder or RAZER Orochi during boot, HOWEVER they do not work in either the USB 3.0 OR USB 2.0 Ports

    The above keyboard and mice are USB 2.0! <-----They are 2.0 NOT 3.0

    Example:

    As windows begins to start up from a bad powering down, the keyboard will NOT work and allow me to go into safe mode or select "boot windows normally" and I have to wait the designated 30-40 seconds for it to automatically select an option.

    Once windows is open my keyboard and mouse both work fine.

    The Keyboard and mouse also work fine once they are in the bios.

    Essentially there is a gap or period of time my mouse/keyboard do NOT work...Which is between the bios and the actual windows OS, (it does not work when windows is "booting", this only causes an issue for the most part when I power the computer down incorrectly or I want to go into safe mode which is an issue.

    I'm not sure how the "legacy" disable/enable options work and which ones do what but from what the description and the manual say it shouldn't make a different.

    Side Note: Sometimes after I enter the bios I will continue to boot directly to the bios until I select "Discard changes and quite" OR I boot with NO keyboard/mouse plugged into the USB ports, either 3.0 or 2.0.
    ------------------------------------------------------------------------------------------------------

    Question:

    When you initially power on the motherboard there are RED LED's ON under the power/reset and dr.debug lcd screen that gives error codes. After the timeout which was default to 1second, which I set to 5seconds those RED LED's turn OFF

    Is this normal or is there some kind of short in my MOBO somewhere?

    It seems to me that the led's behind the power and the reset button would most likely stay on as long as the board is powered and running but this may not be the case.


    Please get back to me when you can as I would like to sort out these issues as soon as possible.

    If any other info is needed let me know

    Keyboard: Logitech g110 Gaming Keyboard
    Mice: Razer Deathadder, Razer Orochi, Razer Lachesis

  2. #2
    Join Date
    Mar 2011
    Location
    Taiwan
    Posts
    562

    Default Re: ASRock z68 Fatality Professional Keyboard/Mouse Problems and Questions!

    Dear IBlackIHIawk,

    We test Logitech G110 keyboard and Razer Deathadder mouse with BIOS L1.36A, two devices works normally.

    Please kindly update BIOS L1.36A from below link to try.
    Z68 Professional Gen3 beta zone link: ASRock > Products > Motherboard > Fatal1ty Z68 Professional Gen3 > Download

    Thanks!

    Have a nice day
    ASRock TSD
    Emily

  3. #3
    Join Date
    Feb 2012
    Location
    USA
    Posts
    5

    Default Re: ASRock z68 Fatality Professional Keyboard/Mouse Problems and Questions!

    Quote Originally Posted by ASRock TSD - Emily View Post
    Dear IBlackIHIawk,

    We test Logitech G110 keyboard and Razer Deathadder mouse with BIOS L1.36A, two devices works normally.

    Please kindly update BIOS L1.36A from below link to try.
    Z68 Professional Gen3 beta zone link: ASRock > Products > Motherboard > Fatal1ty Z68 Professional Gen3 > Download

    Thanks!

    Have a nice day
    ASRock TSD
    Emily
    Will do, and will update with any other issues and let you know if It does or does now work for other people who may have the same problem as myself.

  4. #4
    Join Date
    Feb 2012
    Location
    USA
    Posts
    5

    Default Re: ASRock z68 Fatality Professional Keyboard/Mouse Problems and Questions!

    Can someone answer this though:

    Question:

    When you initially power on the motherboard there are RED LED's ON under the power/reset and dr.debug lcd screen that gives error codes. After the timeout which was default to 1second, which I set to 5seconds those RED LED's turn OFF

    Is this normal or is there some kind of short in my MOBO somewhere?

    It seems to me that the led's behind the power and the reset button would most likely stay on as long as the board is powered and running but this may not be the case.

  5. #5
    Join Date
    Feb 2012
    Location
    USA
    Posts
    5

    Default Re: ASRock z68 Fatality Professional Keyboard/Mouse Problems and Questions!

    After applying the update "beta" firmware that Emily linked me to, all problems with the keyboard/mouse are now solved for anyone having similar issues.

    It now allows me to plug my keyboard AND mouse into either 3.0 OR 2.0 ports and work before windows recognizes them (after I'm fully booted into windows)

    They both work well in the bios, mid post, and after posting into the OS

    Thank you for the help, and flashing was very easy.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •