Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 5 of 5

Thread: ASRock P67 Extreme 4 - Does not POST with Sidewinder 4 keyboard




  1. #1
    Join Date
    Feb 2012
    Location
    sweden
    Posts
    3

    Default ASRock P67 Extreme 4 - Does not POST with Sidewinder 4 keyboard

    Hello.
    I have the ASRock P67 Extreme 4 moderboard and a Microsoft Sidewinder x4 keyboard.
    It hangs on POST and nothing I do seems to work, except to unplug the keyboard and then plug it in when windows have loaded, which is a pain.
    When I use an old Microsoft Wired 600 keyboard it works fine.

    Also, my mouse get's inverted in UEFI, but I can live with that. (Logitec MX518)

    I have the latest 2.10 BIOS.
    Please help me.

    PS. It does with with the old 1.60 BIOS but I cant change back since 1.60 BIOS does not support the new Intel Rapid Storage drivers.
    Last edited by evolina; 02-10-2012 at 03:27 AM.

  2. #2
    kick's Avatar
    kick is offline Senior Member
    Join Date
    Feb 2009
    Location
    Europe,the wild wild west.
    Posts
    1,223

    Default Re: ASRock P67 Extreme 4 - Does not POST with Sidewinder 4 keyboard

    Assuming there wont be a revised bios which will work:
    All I can suggest is disabling legacy.
    plug it in to a usb 3.0 port and disable usb 3. legacy in uefi
    If you dont need usb legacy at all to get into windows disable both usb 2.0 and usb 3.0 legacy and plug it into a usb 2.0 port n see if that works.
    Current Systems:

    Asrock p67 Extreme6.............. Gigabyte EP-45 UD3 ...................... Gigabyte 73 PVM S2
    Intel i5 2500k 4.8ghz................ Intel Q8400 3.8ghz......................... Intel D820 2.8ghz
    Zalman 10x cooler.................... Coolermaster V8............................ HP cooler
    8GB Gskill ripjaw ddr3.............. 4GB Gskill PI ddr2.......................... 4GB samsung ddr2
    60GB ssd/500GB HDD .............. WD 1TB hdd.................................... Seagate 160GB hdd
    GTX 460 1GB x2 SLI ................. Msi 9600GT 512MB(died) ........... Onboard gx
    Win7 64 ,750w psu(ocz)............ Win7 64 ,520w psu,seasonic...... Win XP pro ,400w psu

    HEC 6A34 case . ....................... Jeantec R2 case............................ Packard Bell case

    hoping to upgrade to http://www.thinkgeek.com/stuff/41/habicase.shtml
    http://www.flixya.com/video/140325/Animal-launching

  3. #3
    Join Date
    Feb 2012
    Location
    sweden
    Posts
    3

    Default Re: ASRock P67 Extreme 4 - Does not POST with Sidewinder 4 keyboard

    If I disable legacy support, how do I get into the BIOS again ?
    Do I have to open the computer and clear cmos or will a keyboard in the ps2 port work?

    Seems a lot of ppl have problems with different keyboards.
    Hopefully they will update the BIOS.

  4. #4
    kick's Avatar
    kick is offline Senior Member
    Join Date
    Feb 2009
    Location
    Europe,the wild wild west.
    Posts
    1,223

    Default Re: ASRock P67 Extreme 4 - Does not POST with Sidewinder 4 keyboard

    Im just going on your post exactly...if you need to type a password before windows boots up, or need to access the uefi,to change something,,youo need a keyboard that is recognised at least.
    You say the only way you can get your x4 keyboard to work is to plug it in after windows boots,and thats annoying.
    a ps2 keyboard should work as it will overide anything else.
    Perhaps you need a windows boot schedule that recognises only the x4 after boot and disables any keyboard that doesnt conform to the x4 specs once your in windows,since the x4 "ghosts"?

    Im just suggesting alternatives.
    Last edited by kick; 02-11-2012 at 09:01 AM.
    Current Systems:

    Asrock p67 Extreme6.............. Gigabyte EP-45 UD3 ...................... Gigabyte 73 PVM S2
    Intel i5 2500k 4.8ghz................ Intel Q8400 3.8ghz......................... Intel D820 2.8ghz
    Zalman 10x cooler.................... Coolermaster V8............................ HP cooler
    8GB Gskill ripjaw ddr3.............. 4GB Gskill PI ddr2.......................... 4GB samsung ddr2
    60GB ssd/500GB HDD .............. WD 1TB hdd.................................... Seagate 160GB hdd
    GTX 460 1GB x2 SLI ................. Msi 9600GT 512MB(died) ........... Onboard gx
    Win7 64 ,750w psu(ocz)............ Win7 64 ,520w psu,seasonic...... Win XP pro ,400w psu

    HEC 6A34 case . ....................... Jeantec R2 case............................ Packard Bell case

    hoping to upgrade to http://www.thinkgeek.com/stuff/41/habicase.shtml
    http://www.flixya.com/video/140325/Animal-launching

  5. #5
    kick's Avatar
    kick is offline Senior Member
    Join Date
    Feb 2009
    Location
    Europe,the wild wild west.
    Posts
    1,223

    Default Re: ASRock P67 Extreme 4 - Does not POST with Sidewinder 4 keyboard

    There are some beta bioses on the german asrock support site . I used to go there a bit as when I got my board early 2011, this support site was new.

    There are/were also links to beta bioses that have been removed from the main asrock site. I tried some on my p67 cos even if flashing failed or the bios didnt suit I knew I wouuld be getting a b3 chipset replacement board soon.
    I now have a spare cmos chip(removed from the b2 board) so I wouldnt be worried about trying some modified bios but if you dont have one or arent prepared to spend the 10 to buy one, any "cure the x4 keyboard bioses" you might find are at your own risk
    Last edited by kick; 02-12-2012 at 05:21 AM.
    Current Systems:

    Asrock p67 Extreme6.............. Gigabyte EP-45 UD3 ...................... Gigabyte 73 PVM S2
    Intel i5 2500k 4.8ghz................ Intel Q8400 3.8ghz......................... Intel D820 2.8ghz
    Zalman 10x cooler.................... Coolermaster V8............................ HP cooler
    8GB Gskill ripjaw ddr3.............. 4GB Gskill PI ddr2.......................... 4GB samsung ddr2
    60GB ssd/500GB HDD .............. WD 1TB hdd.................................... Seagate 160GB hdd
    GTX 460 1GB x2 SLI ................. Msi 9600GT 512MB(died) ........... Onboard gx
    Win7 64 ,750w psu(ocz)............ Win7 64 ,520w psu,seasonic...... Win XP pro ,400w psu

    HEC 6A34 case . ....................... Jeantec R2 case............................ Packard Bell case

    hoping to upgrade to http://www.thinkgeek.com/stuff/41/habicase.shtml
    http://www.flixya.com/video/140325/Animal-launching

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •