Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: ASRock Extreme 3 Gen 3 Does not detect Video Card

  1. #1
    Join Date
    Feb 2012

    Default ASRock Extreme 3 Gen 3 Does not detect Video Card

    I have what seems to be a common problem, but despite being common I can't seem to find a solution.

    My PCI-E video card is not detected. The computer runs fine on the integrated graphics, but will not detect the video card. BIOS is set to have PCI-E as the primary video device. There seems to be no way to actually disable the integrated graphics. I've tried putting the card in the other PCI-E slot, but all to no avail. I've even [the-thing-that-must-not-be-mentioned]'ed the video card, thinking that was the problem, but the new one doesn't work either.

    What can I do to get this to work?

    I've also heard rumors of a custom bios solution, though I haven't actually seen any evidence besides the rumors.

    Thanks for the help.

    ASRock Z68 Extreme3 Gen3
    EVGA GTX 570
    Intel Core i5 2400S
    Crucial m4 SSD
    Crucial 4 x 4GB DDR3 RAM
    Last edited by fusama; 02-17-2012 at 07:12 AM.

  2. #2
    Join Date
    Feb 2012
    Texas, USA

    Default Re: ASRock Extreme 3 Gen 3 Does not detect Video Card

    I share your pain. I requested a custom BIOS in hopes of having my video card recognized in either of the pcie slots, and received a reply that the board had been tested with my particular card and should work... but it didn't. But this is what happened:

    I inserted two video cards in at the same time (no crossfire bridge), plugged the power leads into both... and the card in pcie slot #2 immediately sent a video signal to the monitor. The card in slot #4 is still not detected or working, but is necessary to remain in the slot for the other card to function. So, for now, I'm wasting one video card in slot #4 just for the purpose of having the card in slot #2 function.

    Is it a BIOS bug, or a bad mobo? I don't care really because I'm expecting a new MOBO (from a different mfgr) in a few days. Doubt that I'll ever try another ASRock product.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts