Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 5 of 5

Thread: Slow internet connection on brand new Asrock X58 Extreme3




  1. #1
    Join Date
    Feb 2012
    Location
    Denmark
    Posts
    3

    Exclamation Slow internet connection on brand new Asrock X58 Extreme3

    So, I just bought this new Asrock X58 Extreme3 and installed it.

    Everything works fine, I've updated the BIOS aswell - but - my internet is really slow.

    I download with 25 kb/s where I used to download with 8 mb/s on my old motherboard (Intel DX58OG)

    I have 50mb/s into my apartment.

    Could be a driver? But into device management I see that the network card is updated.

    In case it is a driver, where do I find it? I think asrock's website are kinda confusing..

    Help please!

  2. #2
    Lsdmeasap's Avatar
    Lsdmeasap is offline GIGABYTE Guru
    Join Date
    Jan 2008
    Location
    PCB Island
    Posts
    25,940

    Default Re: Slow internet connection on brand new Asrock X58 Extreme3

    Here is the latest Driver from AsRock, these are for Windows 7, if you need other let me know

    32 bit
    ftp://174.142.97.10/drivers/Intel/LA...Win7(7006).zip

    x64
    ftp://174.142.97.10/drivers/Intel/LA...Win7(7006).zip


    And here is the actual latest driver from Realtek (I use and suggest these) (You want - Win7 and WinServer 2008 R2 Auto Installation Program (SID:1483418))
    Realtek

    Also be sure you have installed the latest Intel INF drivers, you can get those here (You want the EXE - first link)
    http://downloadcenter.intel.com/Prod...?ProductID=816
    Last edited by Lsdmeasap; 02-17-2012 at 11:36 PM.

  3. #3
    Join Date
    Feb 2012
    Location
    Denmark
    Posts
    3

    Default Re: Slow internet connection on brand new Asrock X58 Extreme3

    I've installed the LAN driver and the INF drivers.

    Havnt installed the Realtek yet, will do in a moment - but I guess that dosnt solve the connection issue.

  4. #4
    Join Date
    Feb 2012
    Location
    Denmark
    Posts
    3

    Default Re: Slow internet connection on brand new Asrock X58 Extreme3

    Also,

    I have my OS installed onto a SSD drive, while having larger files on my HDD.

    In the BIOS, i see both the SSD and the HDD.

    But in "My Computer", I only see the SSD.

    Now whats wrong? :(

  5. #5
    Lsdmeasap's Avatar
    Lsdmeasap is offline GIGABYTE Guru
    Join Date
    Jan 2008
    Location
    PCB Island
    Posts
    25,940

    Default Re: Slow internet connection on brand new Asrock X58 Extreme3

    Realtek drivers should help, so be sure to install them

    As for your HDD, it sounds like you need to go into disk management and assign a letter to the drive. Search the start menu for diskmgmt.msc, or type that in the run box, then right click the drive in question and choose change drive letter and paths and from there assign a letter for the drive and then it will show up in your My Computer

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •