My A780FullDisplayPort doesn't recognize my Seagate external hard drive. Now none of my computers have an actual USB 3 port, but both of my windows 7 laptops can access it without a problem.

The problem is my A780 doesn't seem to recognize it, it doesn't even show up in the Disk Management screen. I have updated every driver I can find. Do you have any suggestions?




Windows Windows Vista Home Premium Edition (64-bit) Service Pack 2 (Build 6002)
Internet Explorer 9.0.8112.16421
Memory (RAM) 4095 MB
CPU Info AMD Phenom(tm) 8750 Triple-Core Processor
CPU Speed 2394.7 MHz
Sound Card Speakers (Realtek High Definiti |
Realtek Digital Output (Realtek |
Digital Output Device (HDMI) (H |


Display Adapters ATI Radeon HD 3600 Series | ATI Radeon HD 3600 Series | RDPDD Chained DD | RDP Encoder Mirror Driver
Monitors 1x; Generic PnP Monitor |
Screen Resolution 1280 X 1024 - 32 bit
Network Network Present
Network Adapters D-Link DWA-160 Xtreme N Dual Band USB Adapter(rev.A2) | Realtek RTL8168C(P)/8111C(P) Family PCI-E Gigabit Ethernet NIC (NDIS 6.0)
CD / DVD Drives 1x (E: | ) E: HL-DT-STDVDRAM GH24LS70
Ports COM Ports NOT Present. LPT Port NOT Present.
Mouse 5 Button Wheel Mouse Present
Hard Disks C: 781.2GB | D: 1081.8GB
Hard Disks - Free C: 721.4GB | D: 1081.1GB
USB Controllers 7 host controllers.
Firewire (1394) Not Detected
Manufacturer * American Megatrends Inc.
Product Make * To Be Filled By O.E.M.
AC Power Status OnLine
BIOS Info | |
Time Zone Atlantic Standard Time
Battery Status No Battery
Motherboard * ASRock A780FullDisplayPort
SM BIOS P1.90