Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: Has anyone actually received Tech Support from ASRock?




  1. #11
    Join Date
    Feb 2012
    Location
    Melbourne, Victoria, Australia, Australia
    Posts
    18

    Default Re: Has anyone actually received Tech Support from ASRock?

    Quote Originally Posted by hsp25 View Post
    They also deal with consumer complaints. For example online shopping. There are many branches and I have personally used them several times as a last resort
    Thanks, if it has to come to this, then i guess it will, i hope not though

  2. #12
    Join Date
    Jan 2012
    Location
    Australia
    Posts
    122

    Default Re: Has anyone actually received Tech Support from ASRock?

    Tbh it's a slow, pain in the butt type arrangement. Eventually you do get a result though

  3. #13
    Join Date
    Feb 2012
    Location
    Melbourne, Victoria, Australia, Australia
    Posts
    18

    Default Re: Has anyone actually received Tech Support from ASRock?

    Quote Originally Posted by hsp25 View Post
    Tbh it's a slow, pain in the butt type arrangement. Eventually you do get a result though
    Thanks for the reply :) i really hope i don't have to deal with it! surely ASRock will come through :)

  4. #14
    boondocks's Avatar
    boondocks is offline Senior Member
    Join Date
    Apr 2011
    Location
    Live Oak, Florida
    Posts
    1,652

    Default Re: Has anyone actually received Tech Support from ASRock?

    I would at least fill out another support form online. Like the man said, the squeaky wheel gets the grease. It might be helpful to include a phone number: that's how I was contacted.
    Maximus 8 Hero/6700K @ 4.8/4x4GB LPX @ 3200 15-17-17-36 CR1
    Case Labs SM8 w/dual pedestals / Custom water w/ acrylic pipe / Light box
    PowerColor 390Xw/EK block / Samsung 840 Pro 256GBx2 RAID 0 / 128GBx1 SSD's | 3 HDD's / DVD burner
    Dual Aquaero 5 Pro controllers for pumps & fans / FC9 for led's only 2xD5 pwm w/Bitspower tops - MCP35x2 - 3x480 rads/1x240 rad/AP15 fans / EK supremcy
    Seasonic Platinum 1000w custom fabbed/sleeved psu wiring by me

    Wifes: Z77X-UD5H / 3770K w/c with Raystorm copper block & 2 Rads/ Kingston HyperX RAM / Switch 810 case/ PowerColor AX7950 w/EK block
    HTPC: Z68 Pro3 M / 2105

    SOLD:Z97X-UD5H /4790K/F11b mod BIOS/4.8@1.38 4x4GB Kingston Genesis KHX24C11X3K4 2400 RAM 11-13-13-30
    SOLD:Z87X-UD5H /4770K


  5. #15
    Join Date
    Mar 2012
    Location
    Florida, USA
    Posts
    17

    Default Re: Has anyone actually received Tech Support from ASRock?

    I reported my problem to Asrock using their web form; got an auto-reply last Thursday and nothing since.

  6. #16
    boondocks's Avatar
    boondocks is offline Senior Member
    Join Date
    Apr 2011
    Location
    Live Oak, Florida
    Posts
    1,652

    Default Re: Has anyone actually received Tech Support from ASRock?

    Quote Originally Posted by mike2977 View Post
    I reported my problem to Asrock using their web form; got an auto-reply last Thursday and nothing since.
    Send another. Hell, send one every day.
    Maximus 8 Hero/6700K @ 4.8/4x4GB LPX @ 3200 15-17-17-36 CR1
    Case Labs SM8 w/dual pedestals / Custom water w/ acrylic pipe / Light box
    PowerColor 390Xw/EK block / Samsung 840 Pro 256GBx2 RAID 0 / 128GBx1 SSD's | 3 HDD's / DVD burner
    Dual Aquaero 5 Pro controllers for pumps & fans / FC9 for led's only 2xD5 pwm w/Bitspower tops - MCP35x2 - 3x480 rads/1x240 rad/AP15 fans / EK supremcy
    Seasonic Platinum 1000w custom fabbed/sleeved psu wiring by me

    Wifes: Z77X-UD5H / 3770K w/c with Raystorm copper block & 2 Rads/ Kingston HyperX RAM / Switch 810 case/ PowerColor AX7950 w/EK block
    HTPC: Z68 Pro3 M / 2105

    SOLD:Z97X-UD5H /4790K/F11b mod BIOS/4.8@1.38 4x4GB Kingston Genesis KHX24C11X3K4 2400 RAM 11-13-13-30
    SOLD:Z87X-UD5H /4770K


  7. #17
    Join Date
    Aug 2009
    Location
    Birmingham,Great Britain
    Posts
    9,250

    Default Re: Has anyone actually received Tech Support from ASRock?

    suppose it depends where you are in the world,ive dealt with asrock and always got fast response and rma,but i dealt with asrocks netherlands headquarters as no uk based rma dept
    Gigabyte z77x UP4-TH F11c Modded Bios
    Intel i7 3770k 24/7@4.8ghz 1.38v Turbo llc +0.165v dvid multithreading enabled
    Samsung Green(MV-3V4G3D/US) 8GB @2133mhz 9-10-10-21-1t 1.55v
    Thermalright Silver Arrow Cpu Cooler
    1xSamsung 840 pro 256 Gb SSD windows 8.1 pro 64bit
    1xSamsung f4 HD204UI 2tb hard drive Storage
    Powercolor 7970 3gb V3 @1150mhz core/1700mhz mem,1.150v Accelero aftermarket air cooler 55c max
    Razer Lycosa Keyboard
    Logitech X-530 5.1 Speakers
    Lite-On iHAS124-19 24x Sata DVDRW
    K-World Hybrid DVB-T 210SE Digital T.V Card
    L.G E2260V L.E.D 1920x1080 Monitor
    Xfx Pro 750w silver rated Psu 80+
    Fractal Arc Midi Case

    http://i38.tinypic.com/14myvfa.jpg x58 ud5 <=3.8ghz + 4.2ghz Overclock Template!!
    http://www.youtube.com/user/warren304#p/u Visit Me On Youtube

    Lots Of Gaming Videos With X58 Ud5 System And Gpu On My Youtube Channel!!
    Just Uploaded New Battlefield 4 Video!!!!!!!!!!!!!!!!!!!!!!

  8. #18
    Join Date
    Feb 2012
    Location
    Melbourne, Victoria, Australia, Australia
    Posts
    18

    Default Re: Has anyone actually received Tech Support from ASRock?

    Thanks for the replies, I've filled out another one recently, i might just have to keep filling them out.

  9. #19
    Join Date
    Mar 2011
    Location
    Taiwan
    Posts
    562

    Default Re: Has anyone actually received Tech Support from ASRock?

    Dear silverman,

    Sorry for my late reply.

    Due to we don't have Gigabyte GeForce GTX 560 1GB Super Overclock, we test Z68 Extreme3 Gen3 with ASUS GTX560Ti.
    System works well.

    Please kindly refer to below suggestions for testing.
    1. Clear CMOS to try.
    2. Plug the VGA card to another PCI-E slots to try.
    3. If possible, please kindly test the VGA card to another system to check whether the VGA card is fine.

    If the problem still cannot be solved, please kindly refer to below link to contact your local distributor to check your system.
    Link: ASRock > Where to buy

    Thank you!

    Have a nice day
    ASRock TSD
    Emily

  10. #20
    Join Date
    Feb 2012
    Location
    Melbourne, Victoria, Australia, Australia
    Posts
    18

    Default Re: Has anyone actually received Tech Support from ASRock?

    Quote Originally Posted by ASRock TSD - Emily View Post
    Dear silverman,

    Sorry for my late reply.

    Due to we don't have Gigabyte GeForce GTX 560 1GB Super Overclock, we test Z68 Extreme3 Gen3 with ASUS GTX560Ti.
    System works well.

    Please kindly refer to below suggestions for testing.
    1. Clear CMOS to try.
    2. Plug the VGA card to another PCI-E slots to try.
    3. If possible, please kindly test the VGA card to another system to check whether the VGA card is fine.

    If the problem still cannot be solved, please kindly refer to below link to contact your local distributor to check your system.
    Link: ASRock > Where to buy

    Thank you!

    Have a nice day
    ASRock TSD
    Emily
    Thanks for the reply here aswell, as i said in the inbox message, i have tried all three of those options, and is it possible for ASRock to test with the exact card that i use, and just wondering if you tested with the same setup as mine, as i noticed a large number of people having similar problems also use the 2500k CPU.
    Thankyou

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •