Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Has anyone actually received Tech Support from ASRock?




  1. #1
    Join Date
    Feb 2012
    Location
    Melbourne, Victoria, Australia, Australia
    Posts
    18

    Default Has anyone actually received Tech Support from ASRock?

    ^ almost been 2 weeks, and i still haven't had a reply - let alone TSD - Emily, she doesn't reply either, so frustrating, it's been probably 5 weeks since i bought my parts, and i haven't even been able to use my GFX card because of this crap company. Really just want to return the board and never even associate with the company again.

  2. #2
    profJim's Avatar
    profJim is online now Chief Munchkin + moderator
    Join Date
    Dec 2008
    Location
    Tacoma, WA. [USA]
    Posts
    7,811

    Default Re: Has anyone actually received Tech Support from ASRock?

    We can probably help you after you add your hardware list to your forum signature.
    Please describe your video card issues and which steps you've tried.
    Are you using the most recent bios version for your motherboard?
    Have you tried contacting ASRock tech support at ASRock > Support Request Form?
    It might take a week or so for them to respond.
    Q9650 @ 4.10GHz [9x456MHz]
    P35-DS4 [rev: 2.0] ~ Bios: F14
    4x2GB OCZ Reaper PC2-8500 1094MHz @5-5-5-15
    MSI N460GTX Hawk Talon Attack (1GB) video card <---- SLI ---->
    Seasonic SS-660XP2 80 Plus Platinum psu (660w)
    WD Caviar Black WD6401AALS 640GB (data)
    Samsung 840 Pro 256GB SSD (boot)
    SLI @ 16/4 works when running HyperSLI
    Cooler Master 120XL Seidon push/pull AIO cpu water cooling
    Cooler Master HAF XB computer case (RC-902XB-KKN1)
    Asus VH242H 24" monitor [1920x1080]
    MSI N460GTX Hawk (1GB) video card
    Logitech Z-5500 Digital 5.1 Speakers
    win7 x64 sp1 Home Premium
    HT|Omega Claro plus+ sound card
    CyberPower CP1500PFCLCD UPS
    E6300 (R0) @ 3.504GHz [8x438MHz] ~~ P35-DS3L [rev: 1.0] ~ Bios: F9 ~~ 4x2GB Kingston HyperX T1 PC2-8500, 876MHz @4-4-4-10
    Seasonic X650 80+ gold psu (650w) ~~ Xigmatek Balder HDT 1283 cpu cooler ~~ Cooler Master CM 690 case (RC-690-KKN1-GP)
    Samsung 830 128GB SSD MZ-7PC128B/WW (boot) ~~ WD Caviar Black WD6401AALS 640GB (data) ~~ ZM-MFC2 fan controller
    HT|Omega Striker 7.1 sound card ~~ Asus VH242H monitor [1920x1080] ~~ Logitech Z-5500 Digital 5.1 Speakers
    win7 x64 sp1 Home Premium ~~ CyberPower CP1500PFCLCD U.P.S
    .


  3. #3
    boondocks's Avatar
    boondocks is offline Senior Member
    Join Date
    Apr 2011
    Location
    Live Oak, Florida
    Posts
    1,652

    Default Re: Has anyone actually received Tech Support from ASRock?

    Yes, I got a phone call from tech support about a week after I submitted the support request form. I never heard anything from TSD Emily either.
    Maximus 8 Hero/6700K @ 4.8/4x4GB LPX @ 3200 15-17-17-36 CR1
    Case Labs SM8 w/dual pedestals / Custom water w/ acrylic pipe / Light box
    PowerColor 390Xw/EK block / Samsung 840 Pro 256GBx2 RAID 0 / 128GBx1 SSD's | 3 HDD's / DVD burner
    Dual Aquaero 5 Pro controllers for pumps & fans / FC9 for led's only 2xD5 pwm w/Bitspower tops - MCP35x2 - 3x480 rads/1x240 rad/AP15 fans / EK supremcy
    Seasonic Platinum 1000w custom fabbed/sleeved psu wiring by me

    Wifes: Z77X-UD5H / 3770K w/c with Raystorm copper block & 2 Rads/ Kingston HyperX RAM / Switch 810 case/ PowerColor AX7950 w/EK block
    HTPC: Z68 Pro3 M / 2105

    SOLD:Z97X-UD5H /4790K/F11b mod BIOS/4.8@1.38 4x4GB Kingston Genesis KHX24C11X3K4 2400 RAM 11-13-13-30
    SOLD:Z87X-UD5H /4770K


  4. #4
    Join Date
    Feb 2012
    Location
    Melbourne, Victoria, Australia, Australia
    Posts
    18

    Default Re: Has anyone actually received Tech Support from ASRock?

    Quote Originally Posted by profJim View Post
    We can probably help you after you add your hardware list to your forum signature.
    Please describe your video card issues and which steps you've tried.
    Are you using the most recent bios version for your motherboard?
    Have you tried contacting ASRock tech support at ASRock > Support Request Form?
    It might take a week or so for them to respond.
    I've had a thread up for just on two weeks, now gone onto the second page, http://forums.tweaktown.com/asrock/4...ard-issue.html
    ASRock still haven't replied to me after 2 weeks, starting to give up hope ATM, unfortunately I don't think it's possible for me to simply return my motherboard.

  5. #5
    profJim's Avatar
    profJim is online now Chief Munchkin + moderator
    Join Date
    Dec 2008
    Location
    Tacoma, WA. [USA]
    Posts
    7,811

    Default Re: Has anyone actually received Tech Support from ASRock?

    Have you checked the ASRock site to see if there are any beta bios versions for your motherboard?
    Most of the graphics card solutions I've seen here are often solved with a "special" beta bios that ASRock TSD sends to the owner.

    I've seen way too many tech support posts where the best thing anyone could say about tech support is that their "service" is half-fast at best. There are too many problems with most tech support departments; no one company has a monopoly on poor service. The video card problem seems to be quite common with many of the current ASRock motherboards.

    The squeaky wheel gets the grease.

    It's time for you to check out what specific consumer rights you have where you live. Here in the states, we can contact the attorney general's office to investigate fraudulent or illegal business practices. Do you have a small claims court option in Australia?
    RMA discussions about problems are not allowed in the forums, but we are free to discuss technical issues as long as there isn't any company bashing.
    Q9650 @ 4.10GHz [9x456MHz]
    P35-DS4 [rev: 2.0] ~ Bios: F14
    4x2GB OCZ Reaper PC2-8500 1094MHz @5-5-5-15
    MSI N460GTX Hawk Talon Attack (1GB) video card <---- SLI ---->
    Seasonic SS-660XP2 80 Plus Platinum psu (660w)
    WD Caviar Black WD6401AALS 640GB (data)
    Samsung 840 Pro 256GB SSD (boot)
    SLI @ 16/4 works when running HyperSLI
    Cooler Master 120XL Seidon push/pull AIO cpu water cooling
    Cooler Master HAF XB computer case (RC-902XB-KKN1)
    Asus VH242H 24" monitor [1920x1080]
    MSI N460GTX Hawk (1GB) video card
    Logitech Z-5500 Digital 5.1 Speakers
    win7 x64 sp1 Home Premium
    HT|Omega Claro plus+ sound card
    CyberPower CP1500PFCLCD UPS
    E6300 (R0) @ 3.504GHz [8x438MHz] ~~ P35-DS3L [rev: 1.0] ~ Bios: F9 ~~ 4x2GB Kingston HyperX T1 PC2-8500, 876MHz @4-4-4-10
    Seasonic X650 80+ gold psu (650w) ~~ Xigmatek Balder HDT 1283 cpu cooler ~~ Cooler Master CM 690 case (RC-690-KKN1-GP)
    Samsung 830 128GB SSD MZ-7PC128B/WW (boot) ~~ WD Caviar Black WD6401AALS 640GB (data) ~~ ZM-MFC2 fan controller
    HT|Omega Striker 7.1 sound card ~~ Asus VH242H monitor [1920x1080] ~~ Logitech Z-5500 Digital 5.1 Speakers
    win7 x64 sp1 Home Premium ~~ CyberPower CP1500PFCLCD U.P.S
    .


  6. #6
    Join Date
    Jan 2012
    Location
    Australia
    Posts
    122

    Default Re: Has anyone actually received Tech Support from ASRock?

    I think what you are talking about profJim, is what we here in Australia call the ombudsman office

  7. #7
    profJim's Avatar
    profJim is online now Chief Munchkin + moderator
    Join Date
    Dec 2008
    Location
    Tacoma, WA. [USA]
    Posts
    7,811

    Default Re: Has anyone actually received Tech Support from ASRock?

    A quick web search using: ombudsman office australia seems to show that the primary goal is to investigate governmental agencies.
    Maybe they can advise you what your options are when you have a consumer complaint that isn't being solved in a timely manner.
    Q9650 @ 4.10GHz [9x456MHz]
    P35-DS4 [rev: 2.0] ~ Bios: F14
    4x2GB OCZ Reaper PC2-8500 1094MHz @5-5-5-15
    MSI N460GTX Hawk Talon Attack (1GB) video card <---- SLI ---->
    Seasonic SS-660XP2 80 Plus Platinum psu (660w)
    WD Caviar Black WD6401AALS 640GB (data)
    Samsung 840 Pro 256GB SSD (boot)
    SLI @ 16/4 works when running HyperSLI
    Cooler Master 120XL Seidon push/pull AIO cpu water cooling
    Cooler Master HAF XB computer case (RC-902XB-KKN1)
    Asus VH242H 24" monitor [1920x1080]
    MSI N460GTX Hawk (1GB) video card
    Logitech Z-5500 Digital 5.1 Speakers
    win7 x64 sp1 Home Premium
    HT|Omega Claro plus+ sound card
    CyberPower CP1500PFCLCD UPS
    E6300 (R0) @ 3.504GHz [8x438MHz] ~~ P35-DS3L [rev: 1.0] ~ Bios: F9 ~~ 4x2GB Kingston HyperX T1 PC2-8500, 876MHz @4-4-4-10
    Seasonic X650 80+ gold psu (650w) ~~ Xigmatek Balder HDT 1283 cpu cooler ~~ Cooler Master CM 690 case (RC-690-KKN1-GP)
    Samsung 830 128GB SSD MZ-7PC128B/WW (boot) ~~ WD Caviar Black WD6401AALS 640GB (data) ~~ ZM-MFC2 fan controller
    HT|Omega Striker 7.1 sound card ~~ Asus VH242H monitor [1920x1080] ~~ Logitech Z-5500 Digital 5.1 Speakers
    win7 x64 sp1 Home Premium ~~ CyberPower CP1500PFCLCD U.P.S
    .


  8. #8
    Join Date
    Feb 2012
    Location
    Melbourne, Victoria, Australia, Australia
    Posts
    18

    Default Re: Has anyone actually received Tech Support from ASRock?

    Quote Originally Posted by profJim View Post
    Have you checked the ASRock site to see if there are any beta bios versions for your motherboard?
    Most of the graphics card solutions I've seen here are often solved with a "special" beta bios that ASRock TSD sends to the owner.

    I've seen way too many tech support posts where the best thing anyone could say about tech support is that their "service" is half-fast at best. There are too many problems with most tech support departments; no one company has a monopoly on poor service. The video card problem seems to be quite common with many of the current ASRock motherboards.

    The squeaky wheel gets the grease.

    It's time for you to check out what specific consumer rights you have where you live. Here in the states, we can contact the attorney general's office to investigate fraudulent or illegal business practices. Do you have a small claims court option in Australia?
    RMA discussions about problems are not allowed in the forums, but we are free to discuss technical issues as long as there isn't any company bashing.
    Thanks for the reply, and the special beta bios is what i'm anticipating from ASRock, it's just a matter of them actually replying! i'll give it a few more days, and if not i'll just have to see if i can return it from where i bought it, because this whole issue is just starting to get ridiculous at the moment

  9. #9
    Join Date
    Jan 2012
    Location
    Australia
    Posts
    122

    Default Re: Has anyone actually received Tech Support from ASRock?

    They also deal with consumer complaints. For example online shopping. There are many branches and I have personally used them several times as a last resort

  10. #10
    profJim's Avatar
    profJim is online now Chief Munchkin + moderator
    Join Date
    Dec 2008
    Location
    Tacoma, WA. [USA]
    Posts
    7,811

    Default Re: Has anyone actually received Tech Support from ASRock?

    Good to know, thanks for the update.
    Q9650 @ 4.10GHz [9x456MHz]
    P35-DS4 [rev: 2.0] ~ Bios: F14
    4x2GB OCZ Reaper PC2-8500 1094MHz @5-5-5-15
    MSI N460GTX Hawk Talon Attack (1GB) video card <---- SLI ---->
    Seasonic SS-660XP2 80 Plus Platinum psu (660w)
    WD Caviar Black WD6401AALS 640GB (data)
    Samsung 840 Pro 256GB SSD (boot)
    SLI @ 16/4 works when running HyperSLI
    Cooler Master 120XL Seidon push/pull AIO cpu water cooling
    Cooler Master HAF XB computer case (RC-902XB-KKN1)
    Asus VH242H 24" monitor [1920x1080]
    MSI N460GTX Hawk (1GB) video card
    Logitech Z-5500 Digital 5.1 Speakers
    win7 x64 sp1 Home Premium
    HT|Omega Claro plus+ sound card
    CyberPower CP1500PFCLCD UPS
    E6300 (R0) @ 3.504GHz [8x438MHz] ~~ P35-DS3L [rev: 1.0] ~ Bios: F9 ~~ 4x2GB Kingston HyperX T1 PC2-8500, 876MHz @4-4-4-10
    Seasonic X650 80+ gold psu (650w) ~~ Xigmatek Balder HDT 1283 cpu cooler ~~ Cooler Master CM 690 case (RC-690-KKN1-GP)
    Samsung 830 128GB SSD MZ-7PC128B/WW (boot) ~~ WD Caviar Black WD6401AALS 640GB (data) ~~ ZM-MFC2 fan controller
    HT|Omega Striker 7.1 sound card ~~ Asus VH242H monitor [1920x1080] ~~ Logitech Z-5500 Digital 5.1 Speakers
    win7 x64 sp1 Home Premium ~~ CyberPower CP1500PFCLCD U.P.S
    .


Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •