Hello! I have had zero issues with my build until now. since i have the P67 and i5 2500k i decided to try the auto overclocking feature in the BIOS. i tried the 4.2GHz profile saved and exited and booted into windows just fine. opend CPUz and it showed a 1.6GHz clock. i restarted and disabled intel speedstep tech in the bios, saved and booted into windows. i opened CPUz again and it still showed the 1.6GHz clock. i googled a bit and found out that i should try disabling C1E in the BIOS so i did that saved then booted into windows again and yet again CPUz showed a 1.6GHz clock. i said the hell with it and restarted, entered the bios and enabled the intel speedstep tech and C1E saved and exited now i'm getting this "Windows Error Recovery" screen everytime. i have tried the 'launch startup repair' but that doesn't work and i tried 'start windows normally' and all it does is lock up and restart. i cleared my cmos by using the button on the IO panel and even used the jumper method on the Motherboard and it resets the bios. even though i reset the BIOS and left all settings to default except proper memory tweaks it still will NOT boot into windows, it keeps giving me the "Windows Error Recovery" screen. i tried running the windows7 install disc for a system restore but every restore point fails. now i'm wondering if all the constant restarts in such a short amount of time has caused this error? please help? does it sound like i need to reinstall windows? thanks!!

System:
ASRock P67 Extreme4 Gen3 (bios 1.10)
i5 2500K
Kingston HyperX DDR3 1600MHz 8GB Kit (9-9-9-27)
GTX 560 Ti
WD 640GB SATA HDD
LG Super Multi SATA optical
NOTE: i am using the drivers on the ASRock disc that came with the MB. like i said i have had zero issues until i used the autoclock feature. it's funny that i was able to boot into windows the first few times while overclocked with no problems.