Hey all,

I've upgraded my rig today with a :

- ASRock Z68 Extreme3 Gen3 (mobo)
- Intel i5-2400K boxed (cpu)
- 16Gb (4x4)RipjawsX CL9-9-9-24 (Ram)

It seems the cpu works fine.

There are 4 Dimm slots on the Mobo : DDR3_A1, DDR3_A2, DDR3_B1 and DDR3_B2. (from left to right)

If I put all the Ram in nothing happens, the computer seems to boot, but nothings coming up on the screen.

When I put none of the Ram in the slots, the computer boots.
When I do this with a single Ram in slot 1 (DDR3_A1 ) it boots fine too. (I tried this for every single Ram so RAM should be OK)
the same thing goes for DDR3_A2

If I try to put something in DDR3_B1 or DDR3_B2 the computer won't boot (no matter in wich set-up)
(the manual says to put the ram in slots DDR3_A1,DDR3_B1 , but doesn't boot)

The only way the computer boots now (with max Ram) is when I put it in DDR3_A1, DDR3_A2.

The things I tried sofar :
- looking for an answer on the internet, some problems came close or looked the same , but no solutions.
- checked the mobo for bent pins , everything seems ok.
- refitted cpu.
- reconnected all wiring.
- upped the DRAM voltage to 1.6.
- restored BIOS to default

Am I overlooking something or did I get 2 dead DIMM slots?
Anyone had a similar or the same experience? help would be appreciated.

thanx in advance,