Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 1 of 1

Thread: Z68 Extreme3 Gen3 DOA out of box?




  1. #1
    Join Date
    Apr 2012
    Location
    Montreal
    Posts
    5

    Default Z68 Extreme3 Gen3 DOA out of box?

    Carried over from another thread at request of Acebmxer...

    Acebmxer: @Phipop its starting to look like your problems are different from those of the OP. If you wouldnt mind could you start your own thread as to not get confused with the OP.

    Phipop: OK... I have copied over the appropriate info from the earlier thread below to avoid repeating the details...

    Thanks for your help/time so far!

    *****************************
    The story so far:

    Phipop: I'm having almost the same problem as Kopapa except the fan and power LED don't cycle, just remain on but I get no POST, no beeps, .

    The MB seems dead out of the box. The CPU fan starts and runs but the MB does not start POST, there are no beeps, no LED readout at bottom right and the BIOS does not start... nada

    I have unplugged all other components and removed the RAM, one first then both, and the results are the same. I've removed the USB kybd and wireless mouse and re-connected only a basic PS2 keyboard.

    Asrock Z68 Extreme3 Gen3, Intel I5 2500K, G.Skill Ripjaws X 2x4GB F3-12800CL9D-8GBXL, FSP Aurum Gold 700W, Mushkin Chronos 120G SSD, ASUS DVD+/-RW DRW-24B1ST S, WD Caviar HDD (not yet connected)

    Phipop: I have unplugged all other components (Mushkin 120G SSD, DVD R/RW) and removed the GSkill Ripjaws 2x4G RAM, one first then both, and the results are the same. The power supply is a new FSP Aurum Gold 700W. I can try my old 450W RaidMax (cheapie but always working) but I doubt that's the problem. I also tried with just a PS2 keyboard, BTW.

    Wazza 300: try with another psu first... can remove mb battery for 30 mins then try

    Phipop: OK... I removed the CMOS battery for 30 mins, changed PSU, powered on, waited 2 mins and same result... a spinning CPU fan and power LED is on.

    Just another thought... when I had the DVD reader connected with the MS DVD inserted to install the WIN7 OS, it sounded like it was going through its normal spin up and read cycles. Could there be anything possibly just disabling the video output on the MB's DVI connector?

    Wazza 300: what ports do you have on that mb and monitor? vga? dvi? hdmi? which of those,try on another and see if anything displays,other than that you need a graphic card to test

    Phipop: MB and monitor both have DVI + HDMI, I was using DVI and will get a HDMI cable to try but believe both are derived from same internal GPU so both would fail simultaneously if that's the case. I can try a Radeon 5770 card I have in another I5 Gigabyte MB PC later but had wished to avoid that step until convinced there was nothing else to try.

    Solution: Seat the 12V 8 pin ATX GPU plug properly... embarassing to say the least, but at least nobody else poited this out either

    Now, if I could only get the BIOS to see the SSD after switching to AHCI mode... but that will be another string if necessary.
    Last edited by Phipop; 04-02-2012 at 02:55 AM. Reason: Problem solved
    Asrock Z68 Extreme3 Gen3
    Intel I5 2500K
    G.Skill Ripjaws X 2x4GB F3-12800CL9D-8GBXL
    FSP Aurum Gold 700W
    Mushkin Chronos 120G SSD
    ASUS DVD+/-RW DRW-24B1ST S
    WD Caviar HDD (not yet connected for startup test)
    Basic PS2 keyboard (for startup test only)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •