Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 10 of 10

Thread: Asrock Z68 Extreme7 - PCIE4 slot not recognizing gpus?




  1. #1
    Join Date
    Apr 2012
    Location
    United States
    Posts
    6

    Default Asrock Z68 Extreme7 - PCIE4 slot not recognizing gpus?

    Hi folks, thanks for taking the time to read this.

    I purchased an Asrock Z68 Extreme 7 motherboard in November, and up until now, it has been working splendidly. However, my initial reason for purchasing the motherboard was that I would have the option to add additional gpus in the future. So, I recently purchased a used 5970 and attempted to crossfire that card with my existing 5870. The problem is, no card is recognized in the PCIE4 slot. I can get both cards to display video in several of the other PCIE slots, just not the PCIE4 slot.

    The real frustrating part about this is that the PCIE4 slot is the in-between slot for any multigpu setups. Without it working, the machine is useless for multigpu setups.

    I spent several hours last night crawling the interwebs looking for solutions and have came up with some suggestions, but nothing that has proved useful or resolved the problem.

    Things that I've tried:

    • Made sure 4 pin molex is connected to the motherboard.
    • Made sure all 6 pin power cords are plugged snugly into the back of the card.
    • Made sure to set the default display device to PCI-express.
    • I have the latest bios (1.3). (At least I think this is the latest bios.
    • Re-seated and tested multiple video cards in multiple slots.


    I normally try to avoid posting on forums as I can usually find the answer crawling the interwebs, but I believe I've exhausted my informational resources. I would prefer not to RMA, so I'm hoping someone here has some experience with this issue.

    I am open to any and all suggestions. Thank you.

    My System:
    Intel Core i5 2500k (overclocked to 4.5ghz)
    8GB RAM GSkill Sniper 1866
    HD 5970 and 5870 (currently only have the 5970 in the case)
    HAF X Case
    Asrock Z68 Extreme7 motherboard

    Thanks again.

  2. #2
    Join Date
    Apr 2012
    Location
    United States
    Posts
    6

    Default Re: Asrock Z68 Extreme7 - PCIE4 slot not recognizing gpus?

    Sort of an addendum, according to my bios screen, my UEFI version is - Z68 Extreme7 Gen3 P1.30. Is this the most up to date bios? It looks like it is on the Asrock Website but I saw a number of screenshots that showed very different version numbers.

    What is the most current bios version?

  3. #3
    Join Date
    Apr 2012
    Location
    United States
    Posts
    6

    Default Re: Asrock Z68 Extreme7 - PCIE4 slot not recognizing gpus?

    No suggestions? Anybody?

  4. #4
    Join Date
    Apr 2012
    Location
    France
    Posts
    12

    Default Re: Asrock Z68 Extreme7 - PCIE4 slot not recognizing gpus?

    Hi , where did you put , your first card ? PCI 1 or PC2 ?

    The current Bios is 1.30 or Beta 1.30M
    Last edited by gti1; 04-07-2012 at 04:07 PM.

  5. #5
    Join Date
    Apr 2012
    Location
    United States
    Posts
    6

    Default Re: Asrock Z68 Extreme7 - PCIE4 slot not recognizing gpus?

    Hi there,

    I put my first GPU in PCIE1 slot. Bios is 1.30.

  6. #6
    Join Date
    Apr 2012
    Location
    France
    Posts
    12

    Default Re: Asrock Z68 Extreme7 - PCIE4 slot not recognizing gpus?

    Put the first card in Pci2 and the second in Pci 4 .

  7. #7
    Join Date
    Apr 2012
    Location
    United States
    Posts
    6

    Default Re: Asrock Z68 Extreme7 - PCIE4 slot not recognizing gpus?

    Tried this already, still no go. If I put a card by itself in the PCIe4 slot, shouldn't it be recogized if it's the only card in the system?

  8. #8
    Join Date
    Apr 2012
    Location
    France
    Posts
    12

    Default Re: Asrock Z68 Extreme7 - PCIE4 slot not recognizing gpus?

    Sorry , what i say , was wrong , for two card , you must put the card in pc1 and pc4

    " 3. In CrossFireX TM mode or SLI TM mode, please install PCI Express x16 graphics cards on PCIE1 and PCIE4 slots. Therefore, both these two
    slots will work at x16 bandwidth.

    Asrock Z68 Extreme7 - PCIE4 slot not recognizing gpus?-2012-jpg
    Last edited by gti1; 04-07-2012 at 04:34 PM.

  9. #9
    Join Date
    Apr 2012
    Location
    France
    Posts
    12

    Default Re: Asrock Z68 Extreme7 - PCIE4 slot not recognizing gpus?


  10. #10
    Join Date
    Apr 2012
    Location
    United States
    Posts
    6

    Default Re: Asrock Z68 Extreme7 - PCIE4 slot not recognizing gpus?

    I don't know if it's a bios issue as when I put just one card into the slot by itself, it's not recognized. I also talked with Asrock Support, and they offered me some suggestions, else, they think there may be an issue with the board. I'll report back on my findings.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •