Building a new system and hitting a brick wall that's doing my head in. Mobo is an ASRock A75M, which has 5 SATA III ports and no legacy SATA ports. I have attached a Western Digital Caviar Green WD10EARX drive. I have checked the settings in UEFI, and have tried everything set to ACHI and to IDE, neither mode helps. I have also tried to jumpers on the drive to knock it back to 3.0 gb/sec, to no avail. The drive registers in the BIOS, but it registers as having a capacity of 0.0, hardly helpful. When installing Windows 7, setup picks up that the drive is there, but reports it as 30.0 *Mb*, needless to say, Windows won't have a bar of it. I've tried loading the drivers off the support CD using f6 in setup, and have scanned the whole disc looking for drivers, only one shows as being compatible, and that just loads and leaves the drive as 30.0 Mb. Likewise, I have put in an old SATA II drive and installed Windows on that with the intention of loading the drivers from within Windows. Now Windows will install to the old drive about half the time, the rest of the time it partitions it and then says it can't write to the drive, but I think that's because the drive might be a tad flakey. But even then, the SATA III drive doesn't show up in Windows (it appears in the Storage Management SNAP-In as a 30.0 Mb drive, but that is all and it won't allow any actions to that drive). I'm hoping someone here can give a solution that a) I haven't tried, and b) will work like magic and make the whole mess go away. My next port of call to try is to see if I can get the new drive to register on an older Mobo, but I'm not holding out a great deal of hope for that (aside from the fact that it means me disassembling the new machine and putting the old Mobo in and then tearing it apart again for new system if I get a solution).

Please, any and all advice is extremely welcome at this point. This is the first rebuild that has caused this much grief, usually the extent of my angst on rebuilds arises from the fact I usually cut my hand because they're too big for the insides of PCs. :)