Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 4 of 4

Thread: Fatal1ty Z77 Professional Unknown device (missing ACPI driver?)




  1. #1
    Join Date
    Apr 2012
    Location
    Here
    Posts
    4

    Default Fatal1ty Z77 Professional Unknown device (missing ACPI driver?)

    I just built a new system using Windows 7 64-bit using the new Fatal1ty Z77 Professional board. Setup went smoothly, but there is one minor concern which I can't seem to fix. Under Device Manager there is an "Unknown device" flagged that I can't seem to find a driver for. I believe I installed all the drivers from the included disc with the motherboard and have tried having windows search for a driver online without finding anything. I don't seem to find anything related to the device on ASRock's website either under downloads available for the board.

    Here is what appears under Hardware Ids for the device, anyone know where I can get a driver for it or fix this problem? Thanks in advance.

    ACPI\INT33A0
    *INT33A0
    Last edited by Jamenetic; 04-15-2012 at 03:37 AM.

  2. #2
    Join Date
    Apr 2012
    Location
    United States
    Posts
    4

    Default Re: Fatal1ty Z77 Professional Unknown device (missing ACPI driver?)

    I have the same thing on an ASRock z68 professional gen3 but only after my pc wakes from sleep. On a normal bootup there will be no "unknown devices" in device manager but if I put the computer to sleep, once I wake it up I get a little popup on my taskbar saying "your device is ready to use" (or something like that) and then sure enough in device manager I now have a unknown device.

    The description on mine is similar:

    ACPI\NTN0530 Location: on Intel(R) Z68 Express Chipset Family LPC Interface Controller - 1C44
    *NTN0530

    Once I re-boot my computer there are no longer any unknown devices in device manager so Im guessing im must be something thats having trouble waking from sleep (at least on my computer) Maybe someone with more knowledge has some insight?

  3. #3
    Join Date
    Apr 2012
    Location
    Taipei
    Posts
    1

    Default Re: Fatal1ty Z77 Professional Unknown device (missing ACPI driver?)

    Quote Originally Posted by Jamenetic View Post
    ACPI\INT33A0
    *INT33A0
    Just install Intel Smart Connect software


    Quote Originally Posted by mike84 View Post
    ACPI\NTN0530
    *NTN0530
    It seems to be Nuvoton w836x7hg integrated CIR, try if this can help you.
    Last edited by kaitokid; 04-16-2012 at 06:56 PM.

  4. #4
    Join Date
    Apr 2012
    Location
    Here
    Posts
    4

    Default Re: Fatal1ty Z77 Professional Unknown device (missing ACPI driver?)

    Quote Originally Posted by kaitokid View Post
    Just install Intel Smart Connect software
    That solved it, thanks!

Thread Information

Users Browsing this Thread

There are currently 3 users browsing this thread. (0 members and 3 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •