Hello.

Most of the times when I press the power button everything powers up but computer wont boot (also no signal in monitor). I have to power down the machine from button and then power on (2 times), like that computer boot normally and works just fine.
I already updated to latest BIOS and I already have the latest SSD Firmware.
Please if someone have the same problem or he know a possible solution, share it with me.
So here is my computer's specifications:


<dd style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0px; padding-top: 0px; padding-right: 0px; padding-bottom: 3px; padding-left: 0px; color: rgb(62, 62, 62); font-size: 11px; line-height: 13px; background-color: rgb(242, 246, 248); ">Motherboard: Asrock 970 Extreme3</dd><dd style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0px; padding-top: 0px; padding-right: 0px; padding-bottom: 3px; padding-left: 0px; color: rgb(62, 62, 62); font-size: 11px; line-height: 13px; background-color: rgb(242, 246, 248); ">BIOS: UEFI 32 Mbit Flash ROM 1.40</dd><dd style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0px; padding-top: 0px; padding-right: 0px; padding-bottom: 3px; padding-left: 0px; color: rgb(62, 62, 62); font-size: 11px; line-height: 13px; background-color: rgb(242, 246, 248); ">CPU: amd phenom II x4 960t</dd><dd style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0px; padding-top: 0px; padding-right: 0px; padding-bottom: 3px; padding-left: 0px; color: rgb(62, 62, 62); font-size: 11px; line-height: 13px; background-color: rgb(242, 246, 248); ">Vid: Sapphire 6850 1GB</dd><dd style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0px; padding-top: 0px; padding-right: 0px; padding-bottom: 3px; padding-left: 0px; color: rgb(62, 62, 62); font-size: 11px; line-height: 13px; background-color: rgb(242, 246, 248); ">PSU: Corsair CX500</dd><dd style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0px; padding-top: 0px; padding-right: 0px; padding-bottom: 3px; padding-left: 0px; color: rgb(62, 62, 62); font-size: 11px; line-height: 13px; background-color: rgb(242, 246, 248); ">HDD: OCZ Agility 3
RAM: Corsair Vengeance Blue 4GB (2x2GB) CMZ4GX3M2A1600C9B</dd><dd style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0px; padding-top: 0px; padding-right: 0px; padding-bottom: 3px; padding-left: 0px; color: rgb(62, 62, 62); font-size: 11px; line-height: 13px; background-color: rgb(242, 246, 248); ">Chipset: Northbridge: AMD 970, Southbridge: AMD SB950</dd><dd style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 0px; padding-top: 0px; padding-right: 0px; padding-bottom: 3px; padding-left: 0px; color: rgb(62, 62, 62); font-size: 11px; line-height: 13px; background-color: rgb(242, 246, 248); ">OS: Windows 7</dd>