Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 6 of 6

Thread: Asrock H67M Bios Update L2.02: Onboard graphics not working anymore




  1. #1
    Join Date
    Nov 2011
    Location
    Germany
    Posts
    20

    Default Asrock H67M Bios Update L2.02: Onboard graphics not working anymore

    I have updated my Bios 1.80 to L2.02. Everything is working fine as long as I use my dedicated graphics card. Unfortunately when I start my system connected to onboard graphics it doesn't work. No signal on my monitor. Series 6 Ivy Bridge Bios updates doesn't support onboard graphics? (I'm using a i5-2500k)
    Last edited by Borc; 04-27-2012 at 12:55 AM.

  2. #2
    Join Date
    Sep 2011
    Location
    Darien, Il
    Posts
    38

    Default Re: Asrock H67M Bios Update L2.02: Onboard graphics not working anymore

    You are using a beta bios. In the beta section
    ASRock > Products > Motherboard > H67M > Download
    it says to download a vga driver. I don't know what you os is, but select the proper one and download.

  3. #3
    Join Date
    Nov 2011
    Location
    Germany
    Posts
    20

    Default Re: Asrock H67M Bios Update L2.02: Onboard graphics not working anymore

    Quote Originally Posted by ladlers View Post
    You are using a beta bios. In the beta section
    ASRock > Products > Motherboard > H67M > Download
    it says to download a vga driver. I don't know what you os is, but select the proper one and download.

    The windows driver has nothing to do with it in the startup phase. There is no signal.

  4. #4
    Join Date
    Sep 2011
    Location
    Darien, Il
    Posts
    38

    Default Re: Asrock H67M Bios Update L2.02: Onboard graphics not working anymore

    Perhaps it wouldn't get you into the bios, but you might get a display once windows booted. I don't know how you'd do it tho having no display. Perhaps revert to the old bios, install the driver, and install 202. Beta bioses are an incomplete work. People on these boards have similar problems using hi def tvs where windows results in a display but you don't get any bios boot screens or they're distorted. Perhaps a non beta bios will come out eventually.

  5. #5
    Join Date
    Jan 2012
    Location
    Ontario, Canada
    Posts
    9

    Default Re: Asrock H67M Bios Update L2.02: Onboard graphics not working anymore

    ya, if you can use the GFX card available, i'd suggest you revert to a non beta bios. I only recommend a beta if your specifically having an issue.

    Example, i got a inexpensive 2nd nvidia GFX (dedicated for phys X use) and after i put it in the pci-e slot the system wouldn't POST. With the beta bios all was good, however i have new problem, BIOS can't seem to find Master Boot Record.

  6. #6
    Join Date
    Nov 2011
    Location
    Germany
    Posts
    20

    Default Re: Asrock H67M Bios Update L2.02: Onboard graphics not working anymore

    A downgrade is not recommended actually because it could destroy the bios chip. Also it would be no solution for me because I might upgrade to Ivy Bridge sooner than later and would like to use the integrated graphics when I don't play games. Therefore the onboard graphics should work. I noticed there is no onboard graphics option anymore in the bios, only PCI Express and PCI. In the older 1.x Bios I had the option to change to Onboard.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •