Hi all,

I have an Asrock Z68 Extreme4 Gen3 and originally an 8800GT video card. The 8800GT was installed to the PCIE2.0 slot on my MB but recently died. I bought a new Asus GTX560, however it was too large to fit in the PCIE2.0 slot. As such i had to install it to one of the PCIE3.0 slots. My MB does not seem to know it is there.

My specs are as follows:
Asrock Z68 Extreme4 Gen3
Intel core i5 2500
Asus GTX560
700W Thermaltake TR2

I have read through multiple posts in these forums and tried to following:

  • Reseating the video card several times in both PCIE3.0 slots
  • Upgrading the BIOS to 1.20
  • Resetting the CMOS


Also i have tried the video card in the PCIE2.0 slot with the MB outside the case and it worked. I have contacted Asrock for support but am yet to receive a reply.

What do you guys think i should do? Is there maybe another Asrock support person i can contact directly? Is there a phone number i can try to speak with someone directly (i'm in australia)? I don't mind if i have to return the MB to get a new one, i just want to get this sorted asap.

Thanks,

Stuart