Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: Installations after a format




  1. #1
    Join Date
    May 2012
    Location
    Singapore
    Posts
    2

    Question Installations after a format

    Hi all,

    I recently purchased a z77 Extreme 4 with a 3570k, and would like to check with the peeps here on what is installed (relating to ASRock's stuff) after a fresh format. I'm guessing not every Driver or Utility will be required, just checking what would be the minimal to get the best performance.

    Below listed all that is available for a Windows 7 64bit from ASRock's site.

    Drivers

    • AppCharger ver:1.0.5
    • ASMedia SATA3 Driver ver:1.3.1
    • ASMedia USB 3.0 driver ver:1.10.1.0
    • Broadcom Lan driver ver:14.8.4.1
    • CIR receiver driver ver:20110219
    • INF driver ver:9.3.0.1019
    • Intel Management Engine driver ver:8.0.3.1427
    • Intel Rapid Start driver ver:1.0.0.1021
    • Intel Rapid Storage Technology driver ver:11.1.0.1006
    • Intel Smart Connect driver ver:2.0.1083.0
    • Intel USB 3.0 driver ver:1.0.4.220
    • Lucid Virtu MVP ver:2.1.111
    • Realtek high definition audio driver ver:6559
    • SATA RAID Driver (For system to read from floppy diskette during Windows installation)
    • VGA driver ver:15.26.8.64.2696

    Utility

    • ASRock 3TB+ Unlocker Utility ver:1.0
    • ASRock Extreme Tuning Utility ver:0.1.192
    • ASRock XFast LAN Utility ver:6.61.1880_WHQL
    • ASRock XFast USB Utility ver:3.02.30
    • Instant Boot ver:1.29
    • Intel Rapid Start Utility ver:1.0.5
    • Intel Smart Connect Utility ver:1.0.6
    • THX TruStudio ver:1.00.01

    Thanks in advance~!

  2. #2
    Join Date
    Nov 2009
    Location
    Poland
    Posts
    145

    Default Re: Installations after a format

    Install all drivers - that is obvious.

    Utility:

    ASRock XFast LAN Utility ver:6.61.1880_WHQL
    Intel Rapid Start Utility ver:1.0.5
    THX TruStudio ver:1.00.01 (if you are using onboard audio)

    Disable Smart Connect in UEFI because this is technology designed for mobile devices

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •