Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 4 of 4

Thread: Drivers driving me crazy! Some advice please.




  1. #1
    Join Date
    Apr 2012
    Location
    USA
    Posts
    9

    Default Drivers driving me crazy! Some advice please.

    I have my "rig" up and running...finally. However, I am uncertain about installing certain drivers. I have installed the LAN, SATA3, USB3, VGA, INF, Audio drivers.
    The list below includes drivers that I have NOT installed. I need advice on whether I need or want these drivers.

    Intel Management Engine driver ver:7.0.4.1197
    Intel Rapid Start driver ver:1.0.0.1014
    Intel Smart Connect driver ver:2.0.1083.0
    Intel Rapid Storage Technology driver ver:1.0.1.0.1008_PV

    Also, any any take on whether I should install any of the "ASROCK XFast" utilities or Instant Boot ver:1.26?

    Thanks in advance for your help.
    • ASROCK H61iCafe
    • Intel i3-2120
    • Crucial 64 GB m4 2.5-Inch Solid State Drive SATA 6Gb/s CT064M4SSD2
    • HITACHI 500GB 7200 RPM 16MB Cache SATA 3.0Gb/s 3.5
    • Crucial 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800)
    • Budget machine...no OC, onboard Video, Standard CPU Fan

  2. #2
    Acebmxer's Avatar
    Acebmxer is offline Gigabyte Elite
    Join Date
    May 2009
    Location
    New Jersey, United States
    Posts
    2,817

    Default Re: Drivers driving me crazy! Some advice please.

    Yes you do need the drive Intel Management Engine, and the Intel rapid storage drive which is Intel's Raid/AHCI driver. Only install this if you are using raid. The version you have listed which I think is a typo, I think you meant to type 10.1.0.1008 which is a very old driver. The most recent driver is 11.1.0.1006.
    Main Rig
    Gigabyte z87x-OC
    Haswell i7 4770k - 4.7Ghz @ 1.330v LLC Extreme (L310B492)
    G.Skill F3-1700CL9D-8GBXM DDR3-2133mhz 9-11-10-28 1.65v @ 2800mhz 12-14-14-35 1.7v
    Samsung Green 8GB 2x4GB MV-3V4G3D/US DDR3 1.3v 30nn @ 2200Mhz 11-11-11-32 1.60v
    Sapphire ATI HD 7970 3GB clocked 1200MHz @ 1.181v.
    HiS ATI HD 6950
    Samsung 840 Pro 256GB SSD (boot Drive) on Intel sata3 controller port0
    Corsair Force GT 120 GB Sata3 SSD on Intel sata3 controller port1
    Samsung 320GB HD322GJ 7200 RPM 16M cache on Intel sata3 controller port2
    Sony Optiarc DVD-RW AD-7240S on Intel sata3 controller port5
    CORSAIR CMPSU-850TX PSU
    Swiftech MCP655-B Pump
    EK Supremacy Cpu Block
    Swiftech Mcres Micro Rev 2 Reservoir
    Black Ice GTX Xtreme 360 Radiator





  3. #3
    Join Date
    Apr 2012
    Location
    USA
    Posts
    9

    Default Re: Drivers driving me crazy! Some advice please.

    Thanks for the quick reply. The drivers are taken from ASROCK's driver list for my mobo. ASRock > Products > Motherboard > H61iCafe > Download
    If they are out of date, then ASROCK is out of date.

    I am not using RAID, but I did install this: ASMedia SATA3 Driver ver:1.1.7.110G after setting the BIOS for ACHI. So do I need the Intel Rapid Store/ Intel Management drivers?

    What about the ASROCK XFast utilities? Are they any good or just trouble waiting to happen?
    • ASROCK H61iCafe
    • Intel i3-2120
    • Crucial 64 GB m4 2.5-Inch Solid State Drive SATA 6Gb/s CT064M4SSD2
    • HITACHI 500GB 7200 RPM 16MB Cache SATA 3.0Gb/s 3.5
    • Crucial 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800)
    • Budget machine...no OC, onboard Video, Standard CPU Fan

  4. #4
    Acebmxer's Avatar
    Acebmxer is offline Gigabyte Elite
    Join Date
    May 2009
    Location
    New Jersey, United States
    Posts
    2,817

    Default Re: Drivers driving me crazy! Some advice please.

    Yes most motherboard MFR's are out dated on their drivers. Mostly because they may not have tested them in house and consider them stable, where as the MFR of the drivers have test and verified they are stable. So its suggest you go to the source for newer drivers.

    I am not 100% familur with ASrock motherboards so the ASMedia Sata3 drive might be ok. You may want to check the Device manager and look towards the bottom of the list for "storage controller" or something simular to that. Right click and choose properties, Click the driver tab and it should show you the driver being used. If you dont see the storage controller listed you could try and look at the properties of your SSD and verify. If you see that its using the ASMedia drive or if its using the MSAHCI driver. You then can do a benchmark on your SSD before and or after installing the other drivers and see which one offers the best speed/reliability and choose that way.

    As for the Xfast that is ok to install that will help with USB speeds.
    Main Rig
    Gigabyte z87x-OC
    Haswell i7 4770k - 4.7Ghz @ 1.330v LLC Extreme (L310B492)
    G.Skill F3-1700CL9D-8GBXM DDR3-2133mhz 9-11-10-28 1.65v @ 2800mhz 12-14-14-35 1.7v
    Samsung Green 8GB 2x4GB MV-3V4G3D/US DDR3 1.3v 30nn @ 2200Mhz 11-11-11-32 1.60v
    Sapphire ATI HD 7970 3GB clocked 1200MHz @ 1.181v.
    HiS ATI HD 6950
    Samsung 840 Pro 256GB SSD (boot Drive) on Intel sata3 controller port0
    Corsair Force GT 120 GB Sata3 SSD on Intel sata3 controller port1
    Samsung 320GB HD322GJ 7200 RPM 16M cache on Intel sata3 controller port2
    Sony Optiarc DVD-RW AD-7240S on Intel sata3 controller port5
    CORSAIR CMPSU-850TX PSU
    Swiftech MCP655-B Pump
    EK Supremacy Cpu Block
    Swiftech Mcres Micro Rev 2 Reservoir
    Black Ice GTX Xtreme 360 Radiator





Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •