Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Asrock Z68 Pro3-M version 2.10 bios update




  1. #1
    Join Date
    May 2012
    Location
    Wolverhampton
    Posts
    21

    Question Asrock Z68 Pro3-M version 2.10 bios update

    This is my first post to this forum and looking for inspiration and confirmation.
    I would like to know if anyone has successfully managed to flash to the latest version 2.10 bios
    supporting Ivy Bridge processors.
    I have tried but to no avail, having to revert to version 1.70 using the windows installation method as
    Instant Flash seemed to be disabled after attempting the update.
    Everything seemed fine after a restart and subsequent restarts. However, after a complete Shutdown
    I am unable to post my system. It starts for a second then powers off and continues cycling on and off
    until I power off at the wall and reset the bios.
    Contrary to what Asrock say, I was able to revert to a previous bios version - 1.70 (win). Fortunately,
    I can get the system to work but fear that the Intel ME Interface may be corrupt in some way as I too
    am unable to install the most up to date version of Intel's software with an error message stating that my
    system does not support it.
    I suspect that the new bios version 2.10 may have a bug issue which does not allow the Intel ME F/W to
    install correctly causing the sysmptoms described.
    I would be pleased to hear from anyone who has experienced a similar issue or on the contrary from anyone
    who has successfully managed to update their motherboard's bios.
    Last edited by muscles019; 05-07-2012 at 07:48 PM.

  2. #2
    Join Date
    May 2012
    Location
    South Africa
    Posts
    18

    Default Re: Asrock Z68 Pro3-M version 2.10 bios update

    Don't update to a bios that supports ib unless you are actually putting an ib processor in it. Many of us are having issues with our sb cpu's because of the new firmwares. Out of curiosity, how did you update through windows? I thought only instant flash was available.

  3. #3
    Join Date
    May 2012
    Location
    Wolverhampton
    Posts
    21

    Post Re: Asrock Z68 Pro3-M version 2.10 bios update

    Quote Originally Posted by Avi-K View Post
    Don't update to a bios that supports ib unless you are actually putting an ib processor in it. Many of us are having issues with our sb cpu's because of the new firmwares. Out of curiosity, how did you update through windows? I thought only instant flash was available.
    As I stated in my post, after performing the 2.10 update the board would not post following a complete Shutdown until I had unplugged from the wall and reset bios. I was then able to power up and boot into bios settings, save and continue loading windows.
    From there I was able to use the 1.70 (win) bios - which fortunately I had saved - and then able to revert to that previous bios version. Having now completely reset CMOS all seems well.
    I am using an SB i7 2600K cpu but thought that updating the bios would "future proof" my board in readiness for an IB cpu.
    I hope this thread helps other forum users who may have attempted the 2.10 update and experienced similar difficulties. I also found that Instant Flash was failing once the update had completed with my USB flash drive appearing to lock up the system on reboot.
    It seems Asrock may have omitted something in their bios update as my system didn't reboot and install the MEI as I am lead to believe it should have.
    I have enquired directly with Asrock's Support Team but they have failed to offer a suitable explanation so far.
    Last edited by muscles019; 05-07-2012 at 09:07 PM.

  4. #4
    Join Date
    May 2012
    Location
    Phoenix, AZ
    Posts
    2

    Default Re: Asrock Z68 Pro3-M version 2.10 bios update

    I have the same problem and ill try installing the older Bios 1.7 hope it works

  5. #5
    Join Date
    May 2012
    Location
    Phoenix, AZ
    Posts
    2

    Default Re: Asrock Z68 Pro3-M version 2.10 bios update

    Instant flash isn't allowing me to flash the older versions and its just keep rebooting

  6. #6
    Join Date
    May 2012
    Location
    South Africa
    Posts
    18

    Default Re: Asrock Z68 Pro3-M version 2.10 bios update

    Quote Originally Posted by juanvillegas View Post
    Instant flash isn't allowing me to flash the older versions and its just keep rebooting
    Try what the previous guy did. Pull the plug, boot into windows and load the bios using the windows installer. If pulling the plug don't work, clear the cmos.

  7. #7
    Join Date
    May 2012
    Location
    Wolverhampton
    Posts
    21

    Post Re: Asrock Z68 Pro3-M version 2.10 bios update

    Quote Originally Posted by juanvillegas View Post
    I have the same problem and ill try installing the older Bios 1.7 hope it works
    Yeh, just power down at wall. Reset bios and even clear cmos completely by pulling battery for a few minutes.
    System should then boot and present bios settings. F2 to enter bios and update your settings. Save F10 and restart into windows.
    You will then need the 1.70(WIN) bios to revert to successfully.
    If you don't have the original download PM me with your email address and I'll try and forward a copy to you.
    Please also PM Emily at Asrock to let her know that you too have the same issue. She has advised me to clear CMOS and try
    the 2.10 update again.
    I can't do that until I get home next week although I cannot see it working to be honest.
    Good luck!
    Last edited by muscles019; 05-10-2012 at 11:07 PM.

  8. #8
    Join Date
    May 2012
    Location
    Wolverhampton
    Posts
    21

    Post Re: Asrock Z68 Pro3-M version 2.10 bios update

    Quote Originally Posted by muscles019 View Post
    Yeh, just power down at wall. Reset bios and even clear cmos completely by pulling battery for a few minutes.
    System should then boot and present bios settings. F2 to enter bios and update your settings. Save F10 and restart into windows.
    You will then need the 1.70(WIN) bios to revert to successfully.
    If you don't have the original download PM me with your email address and I'll try and forward a copy to you.
    Please also PM Emily at Asrock to let her know that you too have the same issue. She has advised me to clear CMOS and try
    the 2.10 update again.
    I can't do that until I get home next week although I cannot see it working to be honest.
    Good luck!
    Quick update - Managed to get v2.10 bios working. Seems (from a process of elimination) that the PCI-e Graphics settings were the cause - Memory share set to AUTO by default so manually set to 1024MB as previously used. Presently have nVidia 6200LE installed. Have ordered an ASUS HD6450 with HDMI support & which is classified PCI-e v2.1 compatible whereas the nVidia is the old PCI-e standard.
    However, at present it would seem that INSTANT FLASH still locks up the system if a USB flash device is attached when booting - not an immediate problem if Asrock produces Windows based updates in the future as before.
    I will report further once new card arrives.

  9. #9
    Join Date
    May 2012
    Location
    Wolverhampton
    Posts
    21

    Post Re: Asrock Z68 Pro3-M version 2.10 bios update - INSTANT FLASH ISSUES

    SOLUTION FOUND!!!
    Easiest way I've found to use INSTANT FLASH is to create a small 10MB partition and format with simple FAT file system. Then copy bios ROM file to the root of that partition. As soon as you select Instant Flash from within the bios settings the system automatically searches and finds the ROM file.
    I used this method as I was unable to get F6 to work from the bios boot screen when a USB flash drive was connected.
    Remember it must be formatted as FAT and NOT NTFS.

  10. #10
    Join Date
    May 2012
    Location
    Wolverhampton
    Posts
    21

    Default Re: Asrock Z68 Pro3-M version 2.10 bios update - INSTANT FLASH ISSUES

    Does anyone know of a way of verifying whether the Intel ME F/W updated correctly following the bios update. I've never ever experienced such problems with bios updates as with this one. Asrock, when is v2.20 coming out with a proper solution to all of our issues? We need some positive feedback and answers to our problems!!!
    Last edited by muscles019; 05-19-2012 at 11:45 PM.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •