Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: USB 3 Problems on Fatal1ty Z68 Pro Gen 3 after upgrading BIOS to 2.10




  1. #1
    Join Date
    May 2012
    Location
    Brooklyn, NY
    Posts
    1

    Default USB 3 Problems on Fatal1ty Z68 Pro Gen 3 after upgrading BIOS to 2.10

    I think upgrading the BIOS to 2.10 on my Fatal1ty Z68 Pro Gen3 screwed something up with the ASmedia USB controller. Upgrade process went fine (both the first stage and then ME update after reboot); however, once BIOS was flashed, Windows 7 won't get past the splash screen. Tried safe mode, froze during start-up as well. Grabbed a spare hard drive, formatted it and installed a fresh copy of Win7 on it. At first, things seemed normal; however, when I tried installing the drivers for ASmedia USB 3 controller, system freezes. All other drivers that were not auto-detected by Win7 setup install just fine, except for ASmedia USB 3.

    The worst part is that there's no way to downgrade to the previous version of BIOS (1.30), at least not that I know of. I managed to find the file; however, EZFlash does not see it when I copy it to a USB stick (it does see 2.1 file).

    Does anyone have any suggestions on what to try to get this fixed or know how to downgrade, it would be greatly appreciated. Or is contacting ASRock to try to get the board RMA'd my best resort at this point.

  2. #2
    Join Date
    Apr 2012
    Location
    Boston
    Posts
    13

    Default Re: USB 3 Problems on Fatal1ty Z68 Pro Gen 3 after upgrading BIOS to 2.10

    From a bit of searching I found a program called awdflash.exe. People have seemed to have good luck with installing the firmware they want. I have not used this program myself, nor have I attempted to downgrade any BIOS.

    ASRock might try and blame it on the ASmedia drivers and it might actually be true. even if you decide to try the above program, I would contact them anyways.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •