Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 6 of 6

Thread: asrock 970 exreme 4 questions




  1. #1
    Join Date
    May 2012
    Location
    reno
    Posts
    3

    Default asrock 970 exreme 4 questions

    hi, i just bought this motherboard and have an amd fx4170 and some gskill ram anyway i installed this turned it on and when it turned on it asked for my password well my mouse and keyboard wasnt working so i grab my other keyboard that is wired still didnt work so i turned it off and restarted it hoping it would reconize my keyboard and when i restarted the debug light doesnt come on and no picture also it doesnt beep twice like my old computer but it turns on please help

    oh yeah windows 7 64 bit just in case that matters for some reason
    Last edited by deets78; 05-25-2012 at 08:23 AM.

  2. #2

    Default Re: asrock 970 exreme 4 questions

    Does your motherboard have the latest BIOS installed?

    If you can't see it, there is a sticker on your BIOS chip on your motherboard.

    Clear CMOS then load system defaults in BIOS and hopefully you can boot.

    -=Mark=-
    ps, use puntcuation on your reply. Your post is very hard to read and you are jumping all over the place.

    Post what happens, as in I press power and this happens, then that happens, and I get error message, etc.
    ASRock Z68 Extreme3 Gen3 i7 2600K 8GB (2 x 4GB) G.Skill 1333 CL9 MSI HD 7750 Corsair TX850 80Plus

    GigaByte A75-UD4H AMD A*-3870K 8GB (2X4GB) G.Skill 1866 CL8 On-Chip 6550D Antec EA-450 80Plus Platinum

  3. #3
    Join Date
    May 2012
    Location
    reno
    Posts
    3

    Default Re: asrock 970 exreme 4 questions

    Quote Originally Posted by MarkJohnson View Post
    Does your motherboard have the latest BIOS installed?

    If you can't see it, there is a sticker on your BIOS chip on your motherboard.

    Clear CMOS then load system defaults in BIOS and hopefully you can boot.

    -=Mark=-
    ps, use puntcuation on your reply. Your post is very hard to read and you are jumping all over the place.

    Post what happens, as in I press power and this happens, then that happens, and I get error message, etc.
    hi, thanks for your reply. there is no sticker on the bios. and i did clear cmos yesterday and still nothing happening.
    and how do you system default bios or even update them if i cant see the screen?

  4. #4

    Default Re: asrock 970 exreme 4 questions

    Quote Originally Posted by deets78 View Post
    hi, thanks for your reply. there is no sticker on the bios. and i did clear cmos yesterday and still nothing happening.
    and how do you system default bios or even update them if i cant see the screen?
    There is no little white square sticker with typing on it anywhere?

    does your system have a speaker? What beeps does it make?

    Sounds like you'll need to get a new BIOS chip from ASRock. If you have an older chip to put in (AM2/AM2+/AM3), then you can flash to the newest BIOS. Maybe a local shop will do it for a small fee? You can RMA the board to ASRock and they'll do it for you.

    -=Mark=-
    ASRock Z68 Extreme3 Gen3 i7 2600K 8GB (2 x 4GB) G.Skill 1333 CL9 MSI HD 7750 Corsair TX850 80Plus

    GigaByte A75-UD4H AMD A*-3870K 8GB (2X4GB) G.Skill 1866 CL8 On-Chip 6550D Antec EA-450 80Plus Platinum

  5. #5
    Join Date
    May 2012
    Location
    reno
    Posts
    3

    Default Re: asrock 970 exreme 4 questions

    hi, thanks again for your help. I took it to a shop a week ago or so and he told me my cpu was bad. I so i RMAed the chip got a new one and still nothing. so I pulled the 8 pin power plug out while turned on and nothing. so either my board burned up some how or my power supply is bad. BUT, my 4 pin power plug works with my older board, so i dont know if its possible for the 8 pin to be bad while the 4 pin plug is fine.

    I called the shop i took it to and am taking it back and he's going to plug the board in and see whats up.
    OH, sorry and no there is no white little sticker. i saw it on my old board, but not on this one.
    Last edited by deets78; 06-06-2012 at 11:53 PM.

  6. #6

    Default Re: asrock 970 exreme 4 questions

    Quote Originally Posted by deets78 View Post
    hi, thanks again for your help. I took it to a shop a week ago or so and he told me my cpu was bad. I so i RMAed the chip got a new one and still nothing.
    I'm 99% sure your problem is the CMOS chip. It is probably programmed with the original BIOS and wont read the new CPU. You need to contact ASRock and see about them sending you a new CMOS chip with the latest BIOS.

    so I pulled the 8 pin power plug out while turned on and nothing. so either my board burned up some how or my power supply is bad. BUT, my 4 pin power plug works with my older board, so i don't know if its possible for the 8 pin to be bad while the 4 pin plug is fine.
    OMG!!! Why are you unpluging power from your board while it is running? This alone will kill your computer. You may have to buy a new motherboard now :(

    I called the shop i took it to and am taking it back and he's going to plug the board in and see whats up.
    OH, sorry and no there is no white little sticker. i saw it on my old board, but not on this one.
    I don't know if I'd recommend going back to that computer guy. He obviously isn't very experienced.

    If you take it to another computer store make sure you specifically tell them your motherboard needs a BIOS update for your CPU to work on your motherboard.

    Then cross your fingers that your motherboard did fry from unplugging power leads to your motherboard while it was running.

    -=Mark=-
    Last edited by MarkJohnson; 06-07-2012 at 01:50 AM.
    ASRock Z68 Extreme3 Gen3 i7 2600K 8GB (2 x 4GB) G.Skill 1333 CL9 MSI HD 7750 Corsair TX850 80Plus

    GigaByte A75-UD4H AMD A*-3870K 8GB (2X4GB) G.Skill 1866 CL8 On-Chip 6550D Antec EA-450 80Plus Platinum

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •