Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 6 of 6

Thread: Z68 Extreme3 Gen3 - Display on Screen




  1. #1
    miloosj is offline Junior Member
    Join Date
    Jun 2012
    Location
    Spain
    Posts
    3

    Default Z68 Extreme3 Gen3 - Display on Screen

    Hello, i have bought a Motherboard Z68 Extrem3 Gen3, i installed all the components and all seems to work fine, but when i plug the DVI Cable, i have no response on the screen, I put a Gigabyte GTX 550 Video Card, Intel i7 3770k PRocessor, memory ram Kingston Hyper Blu 4GB x 2 1600 Mhz, and i want to if i have to a solution, or i will have to RMA Thanks.

  2. #2
    Join Date
    Feb 2012
    Location
    Yorkshire, UK
    Posts
    11

    Default Re: Z68 Extreme3 Gen3 - Display on Screen

    You will have to put on bios 2.1, and borrow a older cpu to flash it, or buy a cheap celeron g530. Because you have a new ivybridge cpu, they are not compatible with this motherboard straight out of the box.
    Last edited by deanryan; 06-03-2012 at 06:14 PM.

  3. #3
    miloosj is offline Junior Member
    Join Date
    Jun 2012
    Location
    Spain
    Posts
    3

    Default Re: Z68 Extreme3 Gen3 - Display on Screen

    Thanks you, but with the new ivy bridge cpu, the computer dont work in any way? cuz the Dr debug has a number 55, and i thought it were the memory ram problem, compatibility, because the pc when i turn it on, it start well, not shut down, and the Dr debug, just put number 55, i believe, if the motherboard hasn't the bios, at least it will show something on the screen, like "CPu not recognized" but at least show something on the screen.. Thanks btw fast response ^^
    Last edited by miloosj; 06-03-2012 at 07:39 PM.
    Intel i7 3770k Processor 3.5 Ghz 8 MB
    Gigabyte GTX 550
    Z68 Extrem3 Gen3
    Kingston Hyper Blu 4GB x 2
    HDD 500 GB Western 7600 Rpm
    Sony 24x Rewriter DVD-ROM

  4. #4
    Join Date
    Feb 2012
    Location
    Yorkshire, UK
    Posts
    11

    Default Re: Z68 Extreme3 Gen3 - Display on Screen

    Somebody else posted the same issue last week and they had no screen display either, so im sure its the cpu and not the ram.

  5. #5
    miloosj is offline Junior Member
    Join Date
    Jun 2012
    Location
    Spain
    Posts
    3

    Default Re: Z68 Extreme3 Gen3 - Display on Screen

    I hope you are right, ill try to get the cpu to flash the bios, but i wont have it until the other week, so i post if it works or not, to help ppl who has this problem in future.. Thanks for the answer.
    Intel i7 3770k Processor 3.5 Ghz 8 MB
    Gigabyte GTX 550
    Z68 Extrem3 Gen3
    Kingston Hyper Blu 4GB x 2
    HDD 500 GB Western 7600 Rpm
    Sony 24x Rewriter DVD-ROM

  6. #6
    TTkiraTT is offline Junior Member
    Join Date
    Jan 2013
    Location
    Argentina
    Posts
    14

    Default Re: Z68 Extreme3 Gen3 - Display on Screen

    Quote Originally Posted by miloosj View Post
    I hope you are right, ill try to get the cpu to flash the bios, but i wont have it until the other week, so i post if it works or not, to help ppl who has this problem in future.. Thanks for the answer.
    Can i flash mine? look my gear ii'm not having response from my video card and the odd thing is that used to work fine a week ago ... i tested another video card that actually works and nothing happens still no display only onboard working, i have a Zotac Gtx nvidia 570

    computer used to work fine then 1 day just turned down and its like there is no PCI express anymore :S bios is fine i checked :S

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •