Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 3 of 3

Thread: ASRock H61M with I5-3450 Won't Post




  1. #1
    Join Date
    Jun 2012
    Location
    So Cal
    Posts
    2

    Default ASRock H61M with I5-3450 Won't Post

    Hello,

    Just putting together a simple little system with an ASRock H61M-HVS and a Intel I5-3450 and 8GB of Corsair RAM.

    Fans power up, but the system won't post. Checking all the usual things like memory and CPU seated right and connectors etc and am not seeing anything.

    I did notice looking at the MB specs that this CPU is supported with version 1.9 and newer of the BIOS. I don't know what is on the board now, but is there a chance that if this BIOS is older it isn't digging the CPU? And if so, I don't suppose there is a way to flash the BIOS without dropping a CPU in there that it does like with the current BIOS?

    Any other thoughts on things to check for would be greatly appreciated. Unfortunately I had to drive a long way to get the parts, so I'm not thrilled about having to take anything back.

    Thanks for any advice

  2. #2
    Join Date
    Jun 2012
    Location
    Northern Virginia
    Posts
    1

    Default Re: ASRock H61M with I5-3450 Won't Post

    Quote Originally Posted by Kahuna View Post
    Hello,

    Just putting together a simple little system with an ASRock H61M-HVS and a Intel I5-3450 and 8GB of Corsair RAM.

    Fans power up, but the system won't post. Checking all the usual things like memory and CPU seated right and connectors etc and am not seeing anything.

    I did notice looking at the MB specs that this CPU is supported with version 1.9 and newer of the BIOS. I don't know what is on the board now, but is there a chance that if this BIOS is older it isn't digging the CPU? And if so, I don't suppose there is a way to flash the BIOS without dropping a CPU in there that it does like with the current BIOS?

    Any other thoughts on things to check for would be greatly appreciated. Unfortunately I had to drive a long way to get the parts, so I'm not thrilled about having to take anything back.

    Thanks for any advice

    If you did not originally have a second Gen SandyBridge processor, your board might not be able to update to the latest BIOS. However, You can try this. If you have ANOTHER computer doesnt matter MAC or Windows based. Download the latest BIOS drivers to a thumbdrive from the ASRock website. boot up into your config screen, and do the instant flash update for the bios. after this, you should be able to get to your post screen. and install windows.



    Sucks noone has previously posted to help you. But i hope this helps!

  3. #3
    Join Date
    Jun 2012
    Location
    So Cal
    Posts
    2

    Default Re: ASRock H61M with I5-3450 Won't Post

    Should have updated this sooner. I was able to get a generous friend to loan me a sandy bridge processor. Was able to post with that and get the bios updated. Now all is well. Thanks for following up!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •