Hello all,

I recently just did some upgrades to my computer. I ended up buying the (3.1Ghz) AMD FX 8120 Eight core processor, along with an ASRock 990 FX Extreme3 Motherboard. I installed all of the components in my computer, correctly hooked everything up, and did a clean install. I started restoring all of my files and setting to my computer, and I loved it for about a month.

Now, for some reason, my computer will not wake up from sleep. I can't even figure out why! Everything I have tried has no effect. I tried resetting the BIOS to their default settings, I looked for the 3v battery to take out and reset (My board doesn't have one!), I tried everything in my power options, changed the batteries in my wireless mouse and keyboard, updated my drivers, checked compatibility with my GPU and such. I don't know what it could be. The only way I can get my computer to resume is to unplug it, or to flip the switch on the back of the PSU, and do a cold restart. I hate doing that, my computer is incredibly slow for a full 5 minutes afterwords.

My guess is that there is something screwy with my BIOS. I even tried to use the 'Instant Flash' feature my BIOS has, but I don't think it did much. But maybe someone here can recommend and steer me in the right direction.

Here is my specs,

AMD FX 8120 Eight core processor (3.1Ghz)
ASRock 990 FX Extreme3 Motherboard
ATI HD Radeon 5770
4Gb DDR3 PNY
600 Watt peak Rocketfish PSU
1TB WD Green drive (Horrible boot drive, I know)
2TB WD Green storage drive.

Any help is appreciated!