Hello!

Since upgrading my computer from a H67M-ITX/HT to the Z77E-ITX, I have had several issues with my keyboard (Razer Blackwidow Ultimate). The keyboard itself is recognised by the BIOS and Windows just fine, but Razer's driver (tried v1.03 and v1.04) fails to identify the keyboard as a Blackwidow Ultimate (albeit the keyboard being listed as such in the device manager). On top of that, connecting the keyboard's USB hub to any of the computer's USB ports apparently prevents the computer from entering sleep mode.
Since the keyboard works perfectly fine on another computer and has worked just as well with the old mainboard, my guess is that the issue is mainboard related. Has anyone else had this sort of problem and maybe was able to fix it?

System specs:
Mainboard: Asrock Z77E-ITX, BIOS v1.10
CPU: Intel i5-2500K (@3.3GHz, not overclocked)
RAM: 2 x 4GB Kingston HyperX 1333
GPU: Sapphire Radeon HD 7870 OC GHz Edition
OS: Windows Ultimate N (64b), SP1
Keyboard: Razer Blackwidow Ultimate (1.08 Firmware, 1.04 driver)

Many thanks in advance!