Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: Help. New Asrock Fatal1ty Z77 Pro. No IDE and no LAN after reset




  1. #1
    Join Date
    Jun 2012
    Location
    Spain
    Posts
    5

    Unhappy Help. New Asrock Fatal1ty Z77 Pro. No IDE and no LAN after reset

    First message on this forum, so HI everybody and thanks a lot for helping.

    A few days ago I purchased an Asrock Fatal1ty Z77 Professional motherboard. Put an intel 3770k processor, 32GB of G.Skill DDR3 1600 memory (with XMP1.2), SATA hard disks, SSD, floppy, Benq DVD IDE/PATA recorder and an old NVidia GeForce 6600 that I'm using while my new monitor with Displayport arrives.

    Everything installed and run perfectly for a few days until Friday. Windows stalled, I attributed it to an NVidia driver problem because I had established and disconnected a remote desktop session and, when I got to the PC to continue working, the screen was black. The power button didn't turn off the computer, then after 5 minutes I pushed the reset button. Since then: DVD writer is not detected in BIOS System browser (always says ATA port is empty), LAN appears to be connected at 1Gbps in BIOS even if I disconnect the cable and Windows does not see any LAN device nor the DVD recorder.

    I tried changing BIOS versions back and forth, clearing CMOS, removing battery, all without success. Broadcom DOS utility run from a USB flash drive says there is no Broadcom NIC. As I had migrated my Windows installation from a hard disk to an SSD, I still had the original untouched partition with which I first booted the motherboard (everything was running properly at that time). So I activated the partition on the hard disk and booted from there (just in case it was a Windows problem). But Windows is not the problem: Windows running from the hard disk showed the same lack of DVD and LAN adapters. There are no Dr Debug error codes, just the normal startup sequence. To me, it looks as if something became stuck (I mean, not physically broken but logically blocked) when I hit the reset button, but not even removing the battery with everything unplugged for a whole night has had any positive result.

    Is there any utility that might help bringing back every device on the motherboard to a first time startup condition? Or is RMA my only solution?

    The relevant hardware:
    Motherboard is Asrock Fatal1ty Z77 Professional
    Processor intel 3770k (no overclocking, I was planning on it but didn't have the chance)
    Memory G.Skill Ripjaws Z 32GB (no overclocking) F3-12800CL10Q-32GBZL
    Op System is Windows 7 x64
    Hard disks are Samsung, SATA 2
    SSD is OCZ Vertex 4 with latest firmware

    Items that work: processor, memory, Windows 7, hard disks, SSD, graphic card, sound, USB 2.0 and 3.0 (cannot check IEEE1394), even floppy disk.

    Not working: both LAN adapters (LAN lights do turn on and blink when I connect a cable, but as I said, BIOS sees them always connected and Broadcom DOS utility and Windows don't see them), DVD recorder (can load/eject disks but just that, tried a different unit and a different cable but same behavior).

    Sorry for the long post and thank you very much for your help.
    Last edited by jfma; 06-17-2012 at 08:45 PM.

  2. #2
    Join Date
    Jun 2012
    Location
    Spain
    Posts
    5

    Default Re: Help. New Asrock Fatal1ty Z77 Pro. No IDE and no LAN after reset

    I have finally asked for RMA. Couldn't find any help or solution. Asrock support suggested to try a different PSU, but I haven't got one to try. If hardware is alive but blocked, I suppose disconnecting everything up to the battery would have cleared it. If hardware is already dead, changing PSU won't repair it. I would expect a small PSU problem to first manifest in Windows BSODs, not on IDE/PATA and LAN ports.

    While uninstalling the motherboard, I've noticed that IDE is provided by a VIA VT6330 chip. This chip is installed on the backside of the motherboard and a google search shows similar "not detecting my drives on BIOS" problems on other motherboards. On a particular motherboard disabling this chip on BIOS also disabled a PCIe slot. I'm just guessing, but now I suspect that the problem chip may be this one, and it might be interfering with the Broadcom LAN chip, which also interfaces to the rest of the system as a PCIe card.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •