Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 3 of 3

Thread: Dr. Debug A2 Code On Asrock Z77 Extreme4 Mobo - Help Needed!




  1. #1
    Jack_B is offline Junior Member
    Join Date
    Jul 2012
    Location
    Ireland
    Posts
    2

    Default Dr. Debug A2 Code On Asrock Z77 Extreme4 Mobo - Help Needed!

    Hi all, this is my first post on these forums. I'm kinda desperate atm. Bought all the components & had them delivered for my first self-made custom PC build last week. Finished off screwing everything in and making sure all connections were going to the right place last night. Attempted to boot up machine today for windows installation & the following happens :

    The Asrock splash screen appears briefly, then the standard black screen showing bios date, the mobo type, cpu type & speed & total ram, followed by :

    ""UEFI Defaults have been loaded.
    Press F2 or DEL to Run Setup
    Press F1 to continue""

    Now, f2, del, or f1 don't seem to do anything, in fact no key I press on keyboard seems to move the startup process beyond this stage.

    I checked out the Dr. Debug Led display on the motherboard & I get the code A2 - which according the manual means 'IDE Detect'.That's doesn't make sense to me tbqh, since I don't have any IDE devices, what I have are 3 sata devices, namely a dvd-rw drive, samsung 830 ssd and seagate barracuda 2Tb hdd.

    I've been on some other forums and tried various things suggested such as plug out other sata drives apart from dvd & ssd, and starting up pc again with 1 or 2 ram sticks , rearranging all the ram sticks, holding down the 'clear cmos' switch (while disconnected from power), but all so far to no avail?

    Can I try anything else, or am I unlucky enough to just have a dud board?

  2. #2
    Join Date
    Jun 2009
    Posts
    6

    Default Re: Dr. Debug A2 Code On Asrock Z77 Extreme4 Mobo - Help Needed!

    Maybe try clear CMOS button.

    Oh, you tried that sorry.

  3. #3
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Dr. Debug A2 Code On Asrock Z77 Extreme4 Mobo - Help Needed!

    First, just because the term "IDE" is used, don't take that literally, it likely refers to an issue with any type of drive. It also does not mean the drive is bad.

    What kind of keyboard are you using and where is it connected? If it's wireless, it will not work. The first time you start a PC, you likely will need a directly connected keyboard, USB or maybe even the old PS2 keyboard connector. I bet you simply are not getting any signal from your keyboard to the PC. I must use a PS2 keyboard on another mother board I have, when I clear the BIOS, and it's only a year old.

    If it's a USB keyboard, don't use the USB ports that are outlined in blue, use the grey outlined ones on the boards I/O panel, and directly connected, no USB hubs. The blue ones are USB 3.0, and may not work until their special driver is installed.

    A newly built PC has no drivers for devices, since no OS is installed yet, and what the UEFI/BIOS can recognize after being cleared is limited in many cases. You need to get into the UEFI to set the boot order for the OS installation, set to your optical drive of course.

    Are your drives connected to the Intel SATA ports? The two top ones are for the ASMedia chipset, which most likely won't work on a first boot and before it's driver and an OS is installed. The six darker colored SATA ports are the Intel ports, use those mainly, they are also much better performance-wise than the ASMedia.

    When installing your OS, only have your DVD Optical Drive (OD)and your SSD connected to the board. Your SSD should be in one of the first/top Intel SATA ports, and the OD on one of the Intel ports at the bottom. Check the boards manual, which you can download from ASRocks web site page for your board. The manual is essential to read to understand how to use it, I've built PCs for years, and I would never think of not reading the manual, or at least the portions I need to check to get connections correct, etc.

Thread Information

Users Browsing this Thread

There are currently 3 users browsing this thread. (0 members and 3 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •