Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: HD 7970 not recognized by Z68 Extreme3 Gen3




  1. #1
    Hafe is offline Junior Member
    Join Date
    Jul 2012
    Location
    Illinois
    Posts
    1

    Default HD 7970 not recognized by Z68 Extreme3 Gen3

    This is my first PC build. I have this motherboard and GPU.
    Newegg.com - ASRock Z68 Extreme3 Gen3 LGA 1155 Intel Z68 HDMI SATA 6Gb/s USB 3.0 ATX Intel Motherboard
    Newegg.com - XFX Double D FX-797A-TDBC Radeon HD 7970 Black Edition 3GB 384-bit GDDR5 PCI Express 3.0 x16 HDCP Ready CrossFireX Support Video Card

    Last night when I had no OS, I could not get a display from the video card. Tonight I got Windows 7 installed but it still doesn't show it in my display adapters. I installed the drivers (downloaded from manufacturer's website, because the disc didn't work, because it doesn't recognize that I have a video card.) It is plugged into a PCI Express 3.0 slot (the only one it physically fits into with this case) and it is definitely receiving power, because the fans are on.

    Is there anything I can do at this point short of exchanging the video card or getting a different motherboard?

  2. #2
    profJim's Avatar
    profJim is online now Chief Munchkin + moderator
    Join Date
    Dec 2008
    Location
    Tacoma, WA. [USA]
    Posts
    7,811

    Default Re: HD 7970 not recognized by Z68 Extreme3 Gen3

    Check out a similar problem in http://forums.tweaktown.com/asrock/4...-7850-gpu.html and send a private message (PM) to ASRock TSD - Emily and include a link to this thread.
    I changed the thread title's name from Z38 to Z68.

    We can best help you after you create a detailed hardware list in the PC Specs portion of your
    forum profile http://forums.tweaktown.com/profile.php?do=editprofile at the bottom of the
    profile page or in your forum signature http://forums.tweaktown.com/profile....=editsignature.
    Be sure to include brand names and model numbers.
    Q9650 @ 4.10GHz [9x456MHz]
    P35-DS4 [rev: 2.0] ~ Bios: F14
    4x2GB OCZ Reaper PC2-8500 1094MHz @5-5-5-15
    MSI N460GTX Hawk Talon Attack (1GB) video card <---- SLI ---->
    Seasonic SS-660XP2 80 Plus Platinum psu (660w)
    WD Caviar Black WD6401AALS 640GB (data)
    Samsung 840 Pro 256GB SSD (boot)
    SLI @ 16/4 works when running HyperSLI
    Cooler Master 120XL Seidon push/pull AIO cpu water cooling
    Cooler Master HAF XB computer case (RC-902XB-KKN1)
    Asus VH242H 24" monitor [1920x1080]
    MSI N460GTX Hawk (1GB) video card
    Logitech Z-5500 Digital 5.1 Speakers
    win7 x64 sp1 Home Premium
    HT|Omega Claro plus+ sound card
    CyberPower CP1500PFCLCD UPS
    E6300 (R0) @ 3.504GHz [8x438MHz] ~~ P35-DS3L [rev: 1.0] ~ Bios: F9 ~~ 4x2GB Kingston HyperX T1 PC2-8500, 876MHz @4-4-4-10
    Seasonic X650 80+ gold psu (650w) ~~ Xigmatek Balder HDT 1283 cpu cooler ~~ Cooler Master CM 690 case (RC-690-KKN1-GP)
    Samsung 830 128GB SSD MZ-7PC128B/WW (boot) ~~ WD Caviar Black WD6401AALS 640GB (data) ~~ ZM-MFC2 fan controller
    HT|Omega Striker 7.1 sound card ~~ Asus VH242H monitor [1920x1080] ~~ Logitech Z-5500 Digital 5.1 Speakers
    win7 x64 sp1 Home Premium ~~ CyberPower CP1500PFCLCD U.P.S
    .


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •