Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: Z68 Extreme3 Gen refuses to turn on.




  1. #1

    Default Z68 Extreme3 Gen refuses to turn on.

    I bought this back in early April and today it locked up during boot and refused to turn back on. No lights, no fans, no beeps, no nothing.

    I cleared cmos from rear panel and nothing.

    I decide PSU must have died? I replace PSU and voila! It booted without issue. Ran for a couple of hours and BAM! locked up. I power down and it refuses to come back on.

    I manually test both PSUs as two couldn't have died and sure enough I jump the green wire to black and Voila! the PSU comes on for both of them

    Could the MB be bad? Could the CPU be bad? I wouldn't think it would be a bent pin after almost 4 months of use. Or could it?

    What test could I run to determine the problem?
    -=Mark=-
    ASRock Z68 Extreme3 Gen3 i7 2600K 8GB (2 x 4GB) G.Skill 1333 CL9 MSI HD 7750 Corsair TX850 80Plus

    GigaByte A75-UD4H AMD A*-3870K 8GB (2X4GB) G.Skill 1866 CL8 On-Chip 6550D Antec EA-450 80Plus Platinum

  2. #2

    Default Re: Z68 Extreme3 Gen refuses to turn on.

    Well, I pulled the CPU and the pins look fine. I cleaned the MB and put the 2600K back in and still no power at all.

    Time for an RMA I guess. I'll have to wait until Monday.

    -=Mark=-
    ASRock Z68 Extreme3 Gen3 i7 2600K 8GB (2 x 4GB) G.Skill 1333 CL9 MSI HD 7750 Corsair TX850 80Plus

    GigaByte A75-UD4H AMD A*-3870K 8GB (2X4GB) G.Skill 1866 CL8 On-Chip 6550D Antec EA-450 80Plus Platinum

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •