Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 26

Thread: no Advanced Turbo 30 in uefi bios




  1. #11
    gorygordon's Avatar
    gorygordon is offline Junior Member
    Join Date
    Jul 2012
    Location
    Near Bills stadium
    Posts
    13

    Default Re: no Advanced Turbo 30 in uefi bios

    The no-k oc is for cpu numbers that don't end with a -k. Like i7 2700, i7 2600. See no-K
    What settings did you use to oc?
    I finally heard from "erik lin" at Asrock America and he said to return main board! Normally I would but this would be the second return to ASRock in one year. The first being a faulty z68 ex4 gen3 at the begining of this year.(at my expense) Now they want me to return this z77. I agreed only if they paid for shipping. It's hard to keep buying what I read as a good product when I had and have to return for failure.
    Thanx for getting back

  2. #12
    gorygordon's Avatar
    gorygordon is offline Junior Member
    Join Date
    Jul 2012
    Location
    Near Bills stadium
    Posts
    13

    Thumbs up Re: no Advanced Turbo 30 in uefi bios

    As of 8/3/2012 I now have "Load Advanced CPU OC Setting" in my BIOS Thank's to Emily. It is nice to know that somebody at ASRock has a brain and knows how to use it! KUDOS EMILY!!! You might want to have a talk with "erik lin"at ASRock America and show him this thread. He told me to send the mainboard back for replacement. AGAIN THANK YOU! You guys at TweakTown sure picked a good one!

  3. #13
    Join Date
    Mar 2011
    Location
    Taiwan
    Posts
    562

    Default Re: no Advanced Turbo 30 in uefi bios

    Dear gorygordon,

    Thanks for your confimation.
    It's great!

    I have upload the BIOS (L1.90B) to Z77 Extreme6 beta zone, you could download it from below link to try.
    Z77 Extreme6 beta zone link: ASRock > Products > Z77 Extreme6

    This BIOS will also be released in production BIOS later.

    Thank you very mcuh!!

    Have a nice day
    ASRock TSD
    Emily

  4. #14
    Raikku is offline Junior Member
    Join Date
    Sep 2012
    Location
    Finland
    Posts
    5

    Default Re: no Advanced Turbo 30 in uefi bios

    I have same problem with Extreme 4 Z77, no "auto-oc" profiles in bios, at all. I using 2.00 bios now, but situation with it is same as with ealier 1.20, those options are missing. It's almost impossible to find any info from net about this, this thread is first and only one what I've found. Just like this problems doesn't even exist.

  5. #15
    gorygordon's Avatar
    gorygordon is offline Junior Member
    Join Date
    Jul 2012
    Location
    Near Bills stadium
    Posts
    13

    Default Re: no Advanced Turbo 30 in uefi bios

    Thanx to a brilliant ASRock associate we now have an answer! I will send you an attachment to have the turbo installed in your BIOS. If for some reason it does not work, reply back to this forum and we will figure out something else to do.
    I'm no expert but I got my ASRock Z77 ex 6 to OC at 4.704 without the Turbo. If you need help I can tell you what I did.
    Just found in ASRock site that the solution I got won't work with the Z77 ex 4.

    Maybe if ASRock TSD Emily is reading this forum she can also work on your specific problem.
    Last edited by gorygordon; 09-08-2012 at 10:34 AM. Reason: incorrect info

  6. #16
    Raikku is offline Junior Member
    Join Date
    Sep 2012
    Location
    Finland
    Posts
    5

    Default Re: no Advanced Turbo 30 in uefi bios

    I sent pm to her(and I also sent support email to ASRock in last Friday), so maybe they could give some answers which would clarify the situation. Would like to be able to use those profiles, 'cause I used them with my earlier setups(P67-board) too.

  7. #17
    gorygordon's Avatar
    gorygordon is offline Junior Member
    Join Date
    Jul 2012
    Location
    Near Bills stadium
    Posts
    13

    Default Re: no Advanced Turbo 30 in uefi bios

    I also used the turbo settings in my earlier ASRock Z68 Ex 4 Gen 3 MOBO and they worked fine with that board. Not so with this Z77. Found it easier to set manually in BIOS. It seems these ASRock boards are a bit twitchy. They have nice amenities and a lot of extra perks that other boards are lacking in for the price range. I might continue to buy their products. They can only get better in the making of motherboards in the future, as they keep trying to out do their competition.

  8. #18
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: no Advanced Turbo 30 in uefi bios

    Anything that is "twitchy" with these boards (have you tried another manufactures Z68 and Z77 boards with a Sandy Bridge CPU, and compared their BIOS functioning?) is due to the difficulty of having one UEFI/BIOS work with two different CPUs, ie, Sandy Bridge and Ivy Bridge. It has been a long time, if ever, that two different Intel CPUs can be used with one mother board and chipset pair. When I read that IB CPUs could be used on SB mother boards, I was surprised, but SB CPUs on IB boards is more amazing. Frankly, IMO it is a miracle that the UEFI/BIOS works as well as they do. I would never update the UEFI in my ASUS P67 board since they added support for IB CPUs, and broke several things if you use SB CPUs. ASRock is doing a better job with the UEFI compatibility with SB and IB CPUs than other manufactures are.

    My Z77 EX 4 board with UEFI 2.00, and an i7-2600K, does have the "Optimized OC settings" option available as the first option in the OC Tweaker screen. If it's not called "Turbo 30" or whatever does not matter, it still does the same thing, simply put a few values in some settings just as it would from a profile you saved yourself. If the Z77 EX 4 2.00 UEFI does not show that option for i7-2700K CPUs (hard to believe...), that is a simple fix, and goofy error, since there is no difference between a '2600K and '2700K, other than the stock and turbo multiplier set in them moved up by one. They could also change the text displayed for that option to "Hyper Turbo 45", but it would still just be a built in OC profile.

    There really isn't much to OCing SB or IB CPUs, just change the Turbo multiplier on all cores, maybe set load line calibration to level 1 or leave at Auto, and that's it. You can't find anything about this "problem" on the Internet because it's hardly worth mentioning, if it actually is happening. The real OCing days were with the i7-900 series CPUs, and the Core 2 Duo and Quads, you really had to know what you were doing to get those to OC well.

  9. #19
    Raikku is offline Junior Member
    Join Date
    Sep 2012
    Location
    Finland
    Posts
    5

    Default Re: no Advanced Turbo 30 in uefi bios

    Most important thing is that those options just must be there, as many ppl use them to oc 2600/2700K with Extreme4 Z77, so why I should accept that I don't have them in same mboard? As I said, when I had my older ASRock's P67-board, I oc'd SB with those settings. And I really require that they should make it work now too. I don't know what cause this that in all cases there isn't those options in oc-tweaker screen, and I don't care. I just need that they fix it.

  10. #20
    gorygordon's Avatar
    gorygordon is offline Junior Member
    Join Date
    Jul 2012
    Location
    Near Bills stadium
    Posts
    13

    Default Re: no Advanced Turbo 30 in uefi bios

    parsec : you don't understand what is going on here. we both bought motherboards with functions in advanced bios setting that were not there. whether or not they are good or not is not the point. the function should be there and it is not. we just want to let asrock know that we want the function fixed.

    my advance function was fixed by asrock. Raikku's function should also be fixed. we bought the mobo for this function and it was not there.

Page 2 of 3 FirstFirst 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •