Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 3 of 3 FirstFirst 123
Results 21 to 26 of 26

Thread: no Advanced Turbo 30 in uefi bios




  1. #21
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: no Advanced Turbo 30 in uefi bios

    Ok, I get it, sorry. Actually, I did say it could be a issue with i7-2700K CPUs, but I didn't believe it at the time. It just seemed so strange to me that those auto-OC options could be missing in the UEFI. Note that it seems to be isolated to the i7-2700K, but I'm surprised this was not noticed earlier. The i7-2700K was available six months before the Z77 chipset and IB CPUs were launched, so to miss the detection of that CPU is a basic mistake. It is listed in the CPU support list of the Z77 EX 4 board since UEFI 1.20.

    It seems you two are the first to notice this issue with the UEFI on these boards, so you did ASR and other users of this board a favor by pointing this out. I imagine it is a bug in the UEFI code, rather than the omission of the i7-2700K. I wonder if it was being seen as a non-K CPU?

    Also, it is a shame that the first level of support personnel are so poorly trained that they just tell you to RMA the board, which would have done nothing to fix this issue. Think of all the time, resources, and money that would have been wasted doing that, compared to what some training would cost. Not to mention the customers frustration and unhappiness with the product. That is all to common among the support provided by mother board manufactures. I just don't get it...

  2. #22
    Raikku is offline Junior Member
    Join Date
    Sep 2012
    Location
    Finland
    Posts
    5

    Default Re: no Advanced Turbo 30 in uefi bios

    I just wonder if different production batches of 2700K's could affect to this?
    My cpu is "Costa Rica"-serie, which should be better to oc(than that other, made elsewhere), but maybe it
    could cause this problem(?)

  3. #23
    gorygordon's Avatar
    gorygordon is offline Junior Member
    Join Date
    Jul 2012
    Location
    Near Bills stadium
    Posts
    13

    Default Re: no Advanced Turbo 30 in uefi bios

    Raikku, I don't think production varies. I have same batch(Costs Rica) and am having no problem OCing mine. Like in my specs I have mine OC 'd to 4.7 stable.

  4. #24
    dcaoniye is offline Junior Member
    Join Date
    Sep 2012
    Location
    London
    Posts
    1

    Default Re: no Advanced Turbo 30 in uefi bios

    hierarchical

  5. #25
    Raikku is offline Junior Member
    Join Date
    Sep 2012
    Location
    Finland
    Posts
    5

    Default Re: no Advanced Turbo 30 in uefi bios

    Didn't got answer, neither from ASR or Emily, but... There's new bios to dl, v2.10 and it says "add oc-ez&turbo functions to 2700K"(or something like that...). So... have to install that and try it. Feels quite nice to be one of those ppl who started this and make them to make this update. edit. Installed 2.10 and yes, I now have to options in bios. So thanks to ASR direction to fixing this.
    Last edited by Raikku; 09-15-2012 at 09:27 PM.

  6. #26
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: no Advanced Turbo 30 in uefi bios

    That's exactly what was added to the BIOS of this board. So it was overlooked... stuff happens.

Page 3 of 3 FirstFirst 123

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •