Hello all, registered just for this question (I hope it's in the right forum, I have both Asus and Asrock problems, so I just sort of picked).

I recently bought parts for a computer (build is here Intel i5-3570K, EVGA GeForce GTX 670, Fractal Design Define XL Titanium Grey - System Build - PCPartPicker) and I can't get anything to post. The story goes as follows:

I got all the parts, put everything together in the case and turned it on. I got a cpu error on the Asus motherboard (Asus P8Z77-V). The CPU (Intel Core i5 3750K) fan turned on, but nothing was on the screen and the cpu error light was on. Logically I looked around and found that the CPU was most likely dead and I should RMA it. So I sent it back to Amazon and they sent me a new one.

After I installed the new CPU, it did the same thing. I then called Asus to see what they thought and they determined that it was most likely defective. I then returned it to Newegg (I decided to get a new one from them because it was faster than going through Asus).

I got the new motherboard and tried everything out the same way (still in the case). IT GAVE THE SAME ERROR. So I took everything out of the case to breadboard it and it returned the same error. Now it seemed to me that it was definitely not the motherboard, nor the CPU.

I called Corsair to see about a rail that was missing on the 24-pin ATX connector (false alarm on my part, it was the -5v rail) but the guy walked me through some steps to super-double-check my motherboard. After we found that the motherboard might be bad again, I ran out to a local computer store to pick up an Asrock Z77 Extreme6 (I believe it's essentially the same board in terms of features/specs as the Asus P8Z77-V).

The Asrock board started the cpu fan and the PSU fan, but the Dr. Debug feature didn't turn on at all on the board and gave no error messages.

This is where I am now. I THINK it's the PSU (Corsair TX750M), but I can't say for sure. I have tried using the other cord on the PSU (it's semi-modular) for the CPU power but no dice there. I have also tried all the classic troubleshooting techniques from using only one stick of RAM in various channels to resetting the CMOS.

Hopefully this is enough information. I hope to fix this today. I leave for school in about a week, so I badly want to make this thing work.