Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 3 of 3

Thread: Asrock P67 Pro 3 UEFI 3.1 SpeedStep not disabling




  1. #1
    silver4 is offline Junior Member
    Join Date
    Aug 2012
    Location
    Bucharest
    Posts
    2

    Default Asrock P67 Pro 3 UEFI 3.1 SpeedStep not disabling

    Hi
    I just updated my uefi from 1.9 (I think) to 3.1 from the main page.

    Prior to this I was running my 2500k @ 4.2-4.6 stable, on air, with a TT 120 Extreme, 50C .No tinkering, just bios OC presets.

    Now AXTU is all 1600-4200-1600-4200, even if SpeedStep IS disabled in bios. What do?

    sys: 2500k, P67pro3revb3, 2x4corsair vengeance,Antec 750W PSU

  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Asrock P67 Pro 3 UEFI 3.1 SpeedStep not disabling

    You might be a victim of the updated UEFI/BIOS that allows your board to work with Ivy Bridge CPUs, but which breaks settings for Sandy Bridge CPUs.

    That seems to be a trend with Intel 6 series chipset boards, designed for Sandy Bridge CPUs like your i5-2500K, but said to be compatible with Ivy Bridge CPUs. After updating to a UEFI/BIOS that allow the use of Ivy Bridge CPUs, features that worked for Sandy Bridge CPUs no longer work. There are other threads in this forum about this, and I have seen them in other mother board manufactures forums too. I did not change the UEFI to the latest version for my ASUS P67 board, which included support for Ivy Bridge CPUs, and others that did are having problems.

    If there is some way to change to a previous UEFI version, I would do that, but I don't think that is possible without getting new UEFI chip.

  3. #3
    silver4 is offline Junior Member
    Join Date
    Aug 2012
    Location
    Bucharest
    Posts
    2

    Default Re: Asrock P67 Pro 3 UEFI 3.1 SpeedStep not disabling

    Thanks for the info, and I did use the search on the forum but no luck. I managed to find a way, and the way is: no C's, no c1e, c2, c6. It won't speedstep if I do that.

    But in a prime95 fourier, @4.2, which was my everyday clock : 90C. Bad.

    And in bf3 also it is 10-15C hotter than it was with the old bios with C's enabled.

    So I gather there's no way to downgrade the bios? Cause I sure won't get any ivy bridge since my chip was able to render 3 days nonstop @4.6 on air , 100% cpu usage, 65-70C....

    Curiosity killed the cat, I upgraded to 3.1 because i wanted to see those xfast ram/lan stuff that newer boards have, and dehumidification, whatever that is...stupid me.

    Thanks again m8

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •