Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: ASRock X79 Extreme4 PCIE-3.0 Stutter




  1. #1
    ksosx86's Avatar
    ksosx86 is offline Junior Member
    Join Date
    Sep 2012
    Location
    New York City
    Posts
    7

    Default ASRock X79 Extreme4 PCIE-3.0 bug

    Whenever I run my card in PCI-E 3.0 mode I get random stutters/black screens/driver crashes, etc... usually 30min to an hour into gameplay, this doesn't happen with 2.0

    I've been doing some research and it looks like this isn't an issue specific to the X79 platform, as other users are having the same issue with different chipsets.

    My question is, does anyone here know about a "fix" for this issue? Other than using PCI-E 2.0; I'm aware that there isn't really "much" if any perf. diff between the two in the average video game. That said it's still an odd issue and I'm curious if anyone has found a solution...

    I am aware Intel released a microcode update around June this year that I've heard was intended to address an issue with the PCI-E bus signal timing issues, I'd like to know if ASRock has applied this update to the 2.10 bios or if they intend to add it to the next release as it seems to address the issue I'm experiencing... http://downloadcenter.intel.com/Deta...dType=Firmware

    Also, please don't blame this on the sandy bridge e microarchitecture for not being truly pci-e 3.0 compliant, as it's an issue that's also occuring with some ivy bridge users as well...and there's 3930K users out there running in pci-e 3.0 mode without this problem.
    http://www.evga.com/forums/tm.aspx?m...e=1&print=true
    http://forum.giga-byte.co.uk/index.php?topic=9403.0
    http://www.tomshardware.com/forum/36...bridge-systems
    http://hardforum.com/showthread.php?p=1038962857
    http://forum.giga-byte.co.uk/index.p...ic,9144.0.html

    Just to be clear I am not blaming ASRock for anything, I am just asking if it's something within their power to fix/address.
    Last edited by ksosx86; 09-14-2012 at 03:44 PM.
    Intel Core i7-3930K *C2 rev* | 16GB PNY XLR8 DDR3-2133| ASRock X79 Extreme4 | PNY Nvidia GTX 670 2GB | Windows 7 x64, OS X Mountain Lion, Ubuntu 12.04 LTS

  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: ASRock X79 Extreme4 PCIE-3.0 Stutter

    NVIDIA released a new WHQL driver today, which might help:

    NVIDIA DRIVERS 306.23WHQL

  3. #3
    ksosx86's Avatar
    ksosx86 is offline Junior Member
    Join Date
    Sep 2012
    Location
    New York City
    Posts
    7

    Default Re: ASRock X79 Extreme4 PCIE-3.0 Stutter

    Quote Originally Posted by parsec View Post
    NVIDIA released a new WHQL driver today, which might help:

    NVIDIA DRIVERS 306.23WHQL
    Hi parsec,
    I tried your suggestion and installed the latest drivers from NVIDIA *306.23*, however I am still having the issue with PCI-E 3.0, unfortunately it doesn't solve anything with that at all.
    Intel Core i7-3930K *C2 rev* | 16GB PNY XLR8 DDR3-2133| ASRock X79 Extreme4 | PNY Nvidia GTX 670 2GB | Windows 7 x64, OS X Mountain Lion, Ubuntu 12.04 LTS

  4. #4
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: ASRock X79 Extreme4 PCIE-3.0 Stutter

    Do you have the latest version of the Intel Management Engine (IME) installed? The version on your boards download page is not really new, and is the same one Intel supplies for their own X79 boards, so yours may be up to date, but just a thought. The IME is needed to get the PCIe 3.0 lanes working correctly.

    Intel has a newer version of the inf files installation program, 9.2.3.1023, which is newer than the one on your boards download page.

  5. #5
    ksosx86's Avatar
    ksosx86 is offline Junior Member
    Join Date
    Sep 2012
    Location
    New York City
    Posts
    7

    Default Re: ASRock X79 Extreme4 PCIE-3.0 Stutter

    Quote Originally Posted by parsec View Post
    Do you have the latest version of the Intel Management Engine (IME) installed? The version on your boards download page is not really new, and is the same one Intel supplies for their own X79 boards, so yours may be up to date, but just a thought. The IME is needed to get the PCIe 3.0 lanes working correctly.

    Intel has a newer version of the inf files installation program, 9.2.3.1023, which is newer than the one on your boards download page.
    Yeah, I've been running the latest ones from Intel's site, the only thing I've got from the ASRock download page is the USB 3.0 drivers, I'm still having the PCI-E 3.0 bug even with the latest Intel drivers from the Intel site.
    Last edited by ksosx86; 09-16-2012 at 02:12 PM.
    Intel Core i7-3930K *C2 rev* | 16GB PNY XLR8 DDR3-2133| ASRock X79 Extreme4 | PNY Nvidia GTX 670 2GB | Windows 7 x64, OS X Mountain Lion, Ubuntu 12.04 LTS

  6. #6
    ksosx86's Avatar
    ksosx86 is offline Junior Member
    Join Date
    Sep 2012
    Location
    New York City
    Posts
    7

    Default Re: ASRock X79 Extreme4 PCIE-3.0 Stutter

    Bump

    Come on! surely someone from ASRock can comment on this, I'm willing to test any beta bios you could make to correct this issue etc, I just want to know whether you're willing to address this issue or if it's nothing you can address at all. Which would be unfortunate seeing as how some SB-E users don't have this particular issue which leads me to believe it can be addressed in a bios revision. However, if not I'd rather you let me know as that would be the fair and right thing to do as opposed to avoiding this topic alltogether.
    Last edited by ksosx86; 09-16-2012 at 02:16 PM.
    Intel Core i7-3930K *C2 rev* | 16GB PNY XLR8 DDR3-2133| ASRock X79 Extreme4 | PNY Nvidia GTX 670 2GB | Windows 7 x64, OS X Mountain Lion, Ubuntu 12.04 LTS

  7. #7
    boondocks's Avatar
    boondocks is offline Senior Member
    Join Date
    Apr 2011
    Location
    Live Oak, Florida
    Posts
    1,652

    Default Re: ASRock X79 Extreme4 PCIE-3.0 Stutter

    I would try contacting Asrock support. The chances of getting any kind of answer at all is better than on the forum, although they do surprise you sometimes. I've put in support tickets before with a phone number and they have called me, FWIW.
    Maximus 8 Hero/6700K @ 4.8/4x4GB LPX @ 3200 15-17-17-36 CR1
    Case Labs SM8 w/dual pedestals / Custom water w/ acrylic pipe / Light box
    PowerColor 390Xw/EK block / Samsung 840 Pro 256GBx2 RAID 0 / 128GBx1 SSD's | 3 HDD's / DVD burner
    Dual Aquaero 5 Pro controllers for pumps & fans / FC9 for led's only 2xD5 pwm w/Bitspower tops - MCP35x2 - 3x480 rads/1x240 rad/AP15 fans / EK supremcy
    Seasonic Platinum 1000w custom fabbed/sleeved psu wiring by me

    Wifes: Z77X-UD5H / 3770K w/c with Raystorm copper block & 2 Rads/ Kingston HyperX RAM / Switch 810 case/ PowerColor AX7950 w/EK block
    HTPC: Z68 Pro3 M / 2105

    SOLD:Z97X-UD5H /4790K/F11b mod BIOS/4.8@1.38 4x4GB Kingston Genesis KHX24C11X3K4 2400 RAM 11-13-13-30
    SOLD:Z87X-UD5H /4770K


  8. #8
    ksosx86's Avatar
    ksosx86 is offline Junior Member
    Join Date
    Sep 2012
    Location
    New York City
    Posts
    7

    Default Re: ASRock X79 Extreme4 PCIE-3.0 Stutter

    Quote Originally Posted by boondocks View Post
    I would try contacting Asrock support. The chances of getting any kind of answer at all is better than on the forum, although they do surprise you sometimes. I've put in support tickets before with a phone number and they have called me, FWIW.
    Been there done that .. finally some guy emailed me and after a few correspondances he said he'd push it up the chain, but that was a long time ago now and I still haven't heard back on that. I'll keep pressing the issue with him, but hey, I figured that the "wheel that squeekes the most is the one that gets oiled" or however that saying goes, thus it couldn't hurt my chances to post my issue in here as well, since they've got this linked on their site for forums reg. discussuion of their products. Anyways... thanks for the suggestion
    Last edited by ksosx86; 09-16-2012 at 09:09 PM.
    Intel Core i7-3930K *C2 rev* | 16GB PNY XLR8 DDR3-2133| ASRock X79 Extreme4 | PNY Nvidia GTX 670 2GB | Windows 7 x64, OS X Mountain Lion, Ubuntu 12.04 LTS

  9. #9
    boondocks's Avatar
    boondocks is offline Senior Member
    Join Date
    Apr 2011
    Location
    Live Oak, Florida
    Posts
    1,652

    Default Re: ASRock X79 Extreme4 PCIE-3.0 Stutter

    I don't blame you . I probably got lucky, but I had a pretty big thread on here for a while.
    Maximus 8 Hero/6700K @ 4.8/4x4GB LPX @ 3200 15-17-17-36 CR1
    Case Labs SM8 w/dual pedestals / Custom water w/ acrylic pipe / Light box
    PowerColor 390Xw/EK block / Samsung 840 Pro 256GBx2 RAID 0 / 128GBx1 SSD's | 3 HDD's / DVD burner
    Dual Aquaero 5 Pro controllers for pumps & fans / FC9 for led's only 2xD5 pwm w/Bitspower tops - MCP35x2 - 3x480 rads/1x240 rad/AP15 fans / EK supremcy
    Seasonic Platinum 1000w custom fabbed/sleeved psu wiring by me

    Wifes: Z77X-UD5H / 3770K w/c with Raystorm copper block & 2 Rads/ Kingston HyperX RAM / Switch 810 case/ PowerColor AX7950 w/EK block
    HTPC: Z68 Pro3 M / 2105

    SOLD:Z97X-UD5H /4790K/F11b mod BIOS/4.8@1.38 4x4GB Kingston Genesis KHX24C11X3K4 2400 RAM 11-13-13-30
    SOLD:Z87X-UD5H /4770K


  10. #10
    Join Date
    Aug 2009
    Location
    Birmingham,Great Britain
    Posts
    9,250

    Default Re: ASRock X79 Extreme4 PCIE-3.0 Stutter

    just run it in pci-e2 slot for the time being,you wont se any performance drop,only maybe a few fps in tri sli and super resolutions

    as to what the cause is idk,what motherboard memory are you using and tested it for stability? could be bios bug or nvidia driver bug,i know they suffer from microstutter
    Gigabyte z77x UP4-TH F11c Modded Bios
    Intel i7 3770k 24/7@4.8ghz 1.38v Turbo llc +0.165v dvid multithreading enabled
    Samsung Green(MV-3V4G3D/US) 8GB @2133mhz 9-10-10-21-1t 1.55v
    Thermalright Silver Arrow Cpu Cooler
    1xSamsung 840 pro 256 Gb SSD windows 8.1 pro 64bit
    1xSamsung f4 HD204UI 2tb hard drive Storage
    Powercolor 7970 3gb V3 @1150mhz core/1700mhz mem,1.150v Accelero aftermarket air cooler 55c max
    Razer Lycosa Keyboard
    Logitech X-530 5.1 Speakers
    Lite-On iHAS124-19 24x Sata DVDRW
    K-World Hybrid DVB-T 210SE Digital T.V Card
    L.G E2260V L.E.D 1920x1080 Monitor
    Xfx Pro 750w silver rated Psu 80+
    Fractal Arc Midi Case

    http://i38.tinypic.com/14myvfa.jpg x58 ud5 <=3.8ghz + 4.2ghz Overclock Template!!
    http://www.youtube.com/user/warren304#p/u Visit Me On Youtube

    Lots Of Gaming Videos With X58 Ud5 System And Gpu On My Youtube Channel!!
    Just Uploaded New Battlefield 4 Video!!!!!!!!!!!!!!!!!!!!!!

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •